I've succesfully installed Ubuntu (16.04) on top of a VirtualBox (v: 5.2.22r) on top of these two seperate machines:

  1. MacBook - MacOS Mojave
  2. PC - Windows 10

In both machines, I'm able to see the USB drive once it's plugged-in as expected. No problem at all.

But, from Ubuntu-VM user point-of-view, I was unable to see the USB drive from within the Ubuntu-VM once it's fired-on on both machines.

So, I downloaded and installed the "Extension Pack". Then, from the VirtualBox settings, I've checked the "Enable USB Controller" option and added a filter for my USB drive in the "USB Device Filters"

Now, on Mac, the solution above worked after restarting the machine. In windows though, it's a different story. After restarting the machine:

  • The USB drive is detectable by the OS once it is plugged in which is noraml.
  • Once I run the Ubuntu-VM, select the USB drive from the VM Settings (i.e.: Device->USB), the USB drive disappear from windows which is, again, expected.

  • But that is it, it dispapears from Windows Explorer but doesn't show on Ubuntu "Files" sidebar !!

What might be the issue ?!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.