2

I recently installed Ubuntu (18.04.1 LTS) on my old desktop to use as a server. I have been trying to manage the fan speeds, but I cannot get it to work. I started out with this tutorial: How to control fan speed?

After that didn't work I read up that dell's need some more work and tried this: Fan speed in ubuntu: pwmconfig no pwm-capable sensor modules installed

But pwmconfig still says There are no pwm-capable sensor modules installed.

And i8kctl just gives me this: 1.0 1.0 BJ17YG1 -1 -1 -1 -1 -1 -1 -1

I'm not even sure if i8k is for dell desktops, maybe only for laptops. If someone can help me out, that would be awesome, Thanks!

  • What was the output from sensors-detect? – rtaft Dec 3 '18 at 13:04
  • @rtaft - coretemp & it87 And I added i8k – mo523 Dec 3 '18 at 14:51
  • do you know the model of your motherboard? – rtaft Dec 5 '18 at 13:42
  • Handle 0x0002, DMI type 2, 10 bytes Base Board Information Manufacturer: Dell Inc. Product Name: 0CU409 Version: ... Serial Number: ..****. Asset Tag: Features: Board is a hosting board – mo523 Dec 18 '18 at 0:43
0

Neither of the articles you posted mentioned modifying grub, so I assume you have not done that.

You don't need i8k.

Focus on it87 in your searches. One of the common changes is to edit /etc/default/grub and append acpi_enforce_resources=lax at the end of the line GRUB_CMDLINE_LINUX. This thread confirms that it87 needs that grub change: lm sensors not returning CPU temp (it87)

  • I didn't link this, but I've tried it before. I'll try it again, maybe I did something wrong. – mo523 Dec 18 '18 at 0:51
  • Thanks so much! This was the issue. I must of typed it wrong the first time I tried – mo523 Dec 18 '18 at 4:45
0

I've got exactly the same problem with pwmconfig and decided to implement it on my own.

Try this utility https://github.com/ichiriac/ubuntu-smart-fan, it's based on lm-sensors and it will manage the fan speed and log them.

At start you can run it as a monitor in order to seed the fan behavior.

After calibrating the temperature and thresholds you will be able to run it as a daemon on your server, and retrieve a log with fan events

  • Thanks for this. I tried it but I get: Looking for sensors Unable to find any fan device Try to run sensors-detect – mo523 Dec 3 '18 at 14:52
  • Did you ran sudo sensors-detect without any error. If so that means no sensors was detected. Take a look at the /sys/class/hwmon folder, you should find into a subfolder a file named fan[1...x]_label. If you want me to help you could also fill an issue on github, maybe my script does not recognize the configuration – Ioan Chiriac Dec 3 '18 at 20:57
  • yes, it runs fine and I get coretemp & it87 – mo523 Dec 18 '18 at 0:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.