1

After installing Ubuntu 18.10 I wanted to install the new NVIDIA drivers from the GPU Drivers PPA (ppa:graphics-drivers/ppa), but I forgot to check if my graphics card supports nvidia-410.

After the installation and the reboot, I got an error message that the drivers are unsigned and this error message was appearing in a loop even in TTY 2-7.

PKCS#7 signature not signed with a trusted key

I was forced to remove the NVIDIA drivers and to install nvidia-340 as the only option right because the nouveau drivers didn't want to run properly.

When I try to install another drivers version, the installer tells that it will install nvidia-410 packages.

The following additional packages will be installed:
  libnvidia-cfg1-410 libnvidia-common-410 libnvidia-compute-410 libnvidia-compute-410:i386 libnvidia-decode-410 libnvidia-decode-410:i386
  libnvidia-encode-410 libnvidia-encode-410:i386 libnvidia-fbc1-410 libnvidia-fbc1-410:i386 libnvidia-gl-410 libnvidia-gl-410:i386
  libnvidia-ifr1-410 libnvidia-ifr1-410:i386 nvidia-compute-utils-410 nvidia-dkms-410 nvidia-driver-390 nvidia-driver-410
  nvidia-kernel-common-410 nvidia-kernel-source-410 nvidia-utils-410 xserver-xorg-video-nvidia-410

Is it possible to force the installation of a specified drivers version other than nvidia-410?

I tried to install drivers with bash installers from the NVIDIA website, but I'm getting an error:

ERROR: Unable to load the "nvidia-drm" kernel module.
2

APT generally looks for and installs the latest stable version of any package. To achieve what you want, you have to remove the GPU Drivers PPA. But first remove all NVIDIA related software and reboot the operating system. Regarding the error message that the drivers aren't signed, boot into BIOS and disable Secure Boot in the UEFI settings. After having done this, perform these steps ...

  • If you have the original NVIDIA drivers installed : sudo nvidia-installer --uninstall
  • If you have the "Ubuntu drivers version" installed : sudo apt purge nvidia*
  • Reboot the operating system : sudo reboot
  • Remove the PPA : sudo add-apt-repository --remove ppa:graphics-drivers/ppa
  • Update the software sources : sudo apt update
  • Search for available drivers : sudo apt search nvidia*
  • Install the drivers of your choice - an example : sudo apt install nvidia-driver-390
  • Reboot the operating system : sudo reboot

What's important : you can only install and use drivers versions that support your GPU, of course.

  • Not a perfect solution, but for now it works. I am still getting the message: "PKCS#7 signature not signed with a trusted key" even though Secure Boot was already disabled in BIOS. – Gujche Nov 30 '18 at 17:17
  • Hi @Gujche ! Unfortunately there is no other solution, that's how it works on Ubuntu and regarding the message - you just can ignore it, it doesn't prevent the drivers from working - it's meant to be more an information. :) – cl-netbox Nov 30 '18 at 17:23
  • 1
    The search for nvidia gives a lot of unrelated files. I find this gives just drivers and shows model nVidia card ubuntu-drivers devices – oldfred Nov 30 '18 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.