This question already has an answer here:

i want to install openssh from source on Ubuntu. i downloaded the source

  1. ./configure
  2. make
  3. sudo make install

but with this last command, i get the following error:

(cd openbsd-compat && make)
make[1]: Entering directory '/home/pc/Desktop/openssh-7.6p1/openbsd-compat'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/home/pc/Desktop/openssh-7.6p1/openbsd-compat'
./mkinstalldirs /usr/local/bin
make: execvp: ./mkinstalldirs: Permission denied
Makefile:313: recipe for target 'install-files' failed
make: [install-files] Error 127

What can i do please to fix this error ? i can't find a solution !

marked as duplicate by PerlDuck, Fabby, cl-netbox, dessert, karel Dec 1 '18 at 0:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I'd say the Permission denied message indicates you didn't use sudo to run ./mkinstalldirs. – PerlDuck Nov 30 '18 at 14:32
  • ./mkinstalldirs !!! when should use this cmd please ? – Rahal Nov 30 '18 at 14:37
  • Oh. I thought you ran it on yourself. But it is part of the Makefile. Sorry. My fault. Given your other comment (./configure --prefix=/usr/local ...) I suggest running make with sudo, i.e. sudo make. When you want to install to /usr/local then you need sudo permissions. – PerlDuck Nov 30 '18 at 14:52
  • First, thank u so much for answering me sir. i tried to use this two cmd .. but i always get the same error with : sudo make install !!!? what should i do please ? – Rahal Nov 30 '18 at 15:09
  • If you have so many problems compiling and installing openssh from source, why don't you just install the binary package? Do you have special requirements? See How do I build openssh from source?. – PerlDuck Nov 30 '18 at 15:21

Sometimes when compiling, and it depends on how the developer builds his Makefile, he has had to specify the output directory, so he does not give me the errors.

./configure --prefix = /path_for_build
  • i tried to tape this cmd: ./configure --prefix=/usr/local --sysconfdir=/etc/ssh --with-md5-passwords but i always get the same error ! – Rahal Nov 30 '18 at 14:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.