1

I'm getting the following error:

$ sudo apt-get install grass grass-dev qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
grass-dev is already the newest version (7.4.0-1).
python-qgis is already the newest version (1:3.4.2+28bionic).
The following additional packages will be installed:
  qgis-providers
Suggested packages:
  gpsbabel
The following NEW packages will be installed:
  grass qgis qgis-plugin-grass qgis-providers
0 upgraded, 4 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/12.7 MB of archives.
After this operation, 22.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package qgis-providers.
(Reading database ... 398057 files and directories currently installed.)
Preparing to unpack .../qgis-providers_1%3a3.4.2+28bionic_amd64.deb ...
Unpacking qgis-providers (1:3.4.2+28bionic) ...
Selecting previously unselected package qgis.
Preparing to unpack .../qgis_1%3a3.4.2+28bionic_amd64.deb ...
Unpacking qgis (1:3.4.2+28bionic) ...
Selecting previously unselected package qgis-plugin-grass.
Preparing to unpack .../qgis-plugin-grass_1%3a3.4.2+28bionic_amd64.deb ...
Unpacking qgis-plugin-grass (1:3.4.2+28bionic) ...
Selecting previously unselected package grass.
Preparing to unpack .../archives/grass_7.4.0-1_all.deb ...
Unpacking grass (7.4.0-1) ...
Setting up grass (7.4.0-1) ...
Setting up qgis-providers (1:3.4.2+28bionic) ...
/usr/lib/qgis/crssync: symbol lookup error: /usr/lib/libgdal.so.20: undefined symbol: sqlite3_column_table_name
dpkg: error processing package qgis-providers (--configure):
 installed qgis-providers package post-installation script subprocess returned error exit status 127
dpkg: dependency problems prevent configuration of qgis:
 qgis depends on qgis-providers (= 1:3.4.2+28bionic); however:
  Package qgis-providers is not configured yet.

dpkg: error processing package qgis (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
dpkg: dependency problems prevent configuration of qgis-plugin-grass:
 qgis-plugin-grass depends on qgis (= 1:3.4.2+28bionic); however:
  Package qgis is not configured yet.

dpkg: error processing package qgis-plugin-grass (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for shared-mime-info (1.9-2) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 qgis-providers
 qgis
 qgis-plugin-grass
E: Sub-process /usr/bin/dpkg returned an error code (1)

Why is it failing on something to do with sqlite tables?

I followed this: Dependency issues when trying to install qgis python-qgis qgis-plugin-grass

And trying to install:

sudo apt install libmysqlclient-dev 

Produces the same error about qgis for some reason.

This seems to have permanently messed up my system. Anything I try to install produces this error.

Edit for debug

$ dpkg -S /usr/lib/libgdal.so.20
libgdal20: /usr/lib/libgdal.so.20
  • Please add output of dpkg -S /usr/lib/libgdal.so.20 and ldd /usr/lib/libgdal.so.20 to the question. Also note that your install command end with success on clean Ubuntu 18.04.1 LTS VM without PPAs. It opens qgis and reports that it has 2.18 version. Do you have any PPAs added to the system? – N0rbert Nov 29 '18 at 18:37
  • Thanks, @N0rbert. ldd seems to have a lot of output but ldd /usr/lib/libgdal.so.20 grep | gdal returns nothing – Mittenchops Nov 29 '18 at 19:20
  • Please share full output of ldd /usr/lib/libgdal.so.20 and apt-cache policy libgdal20. – N0rbert Nov 29 '18 at 19:22
0

Looks like your libsqlite3 was built without the switch:

-DSQLITE_ENABLE_COLUMN_METADATA

which libgda1.so.20 expects.

  • 1
    That's useful info (can't see how you figured it!), but it would be great if you could advise what OP can do about it... – Zanna May 23 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.