I am trying to set up a Hurricane IPv6 tunnel on my Ubuntu 11.10 computer. I have set up my /etc/network/interfaces file as stated on https://wiki.ubuntu.com/IPv6#Get_connected_with_Hurricane_Electric.

My /etc/network/interfaces file is the following:

auto lo
iface lo inet loopback

auto he-ipv6
iface he-ipv6 inet6 v4tunnel
      address  2001:470:1f06:6::2/64
      netmask  64
      up ip -6 route add default dev he-ipv6
      down ip -6 route del default dev he-ipv6

When I try to start IPv6 by running sudo ifup he-ipv6, I receive the following:

add tunnel sit0 failed: No buffer space available
Failed to bring up he-ipv6.

I have double checked that the data I entered from Hurricane is correct. What is causing this problem, and how can I fix it?

2 Answers 2


Problem 1: the /64 on the end of the address parameter is incorrect. That's what the netmask parameter is for; you should delete the /64 on the end of address.

However, the error you're seeing is what you'd expect if there was already a tunnel configured with the name "he-ipv6". At a guess, you've already run ifup he-ipv6, and it's got as far as creating the tunnel before falling over with an error due to the trailing /64. Try doing

sudo ip tun del he-ipv6

to delete the half-configured tunnel before trying again.

  • I followed your instructions. Running sudo ifup he-ipv6 now works, but test-ipv6.com doesn't detect any IPv6 address, saying that IPv6 only websites will apear to be down for me. What have I done wrong? Also, what should I set the method to under the IPv6 tab of my wired network settings?
    – Aaron Hill
    Commented Mar 3, 2012 at 19:24
  • For the last part of your question, wiki.ubuntu.com/IPv6#Get_connected_with_Hurricane_Electric seems to have quite specific instructions - I'd start there. For the first part, I'd try traceroute6 ipv6.google.com and see what's going on. Do you have any iptables rules (or an upstream firewall) which could be blocking the tunnel traffic?
    – richvdh
    Commented Mar 4, 2012 at 11:53
  • Oops, I missed that last part of the instructions at Ubuntu Wiki. IPv6 is still not working for me. I don't have any firewalls or iptables rules that are blocking the tunnel. When I run the traceroute, it slowly prints out the following: pastebin.ubuntu.com/868333
    – Aaron Hill
    Commented Mar 4, 2012 at 14:56
  • So traffic isn't even getting as far as the Hurricane Electric gateway at the other end of the tunnel. Strange. I assume you have double- and triple-checked that the HE tunnel is configured correctly (particularly your public IPv4 address)? It might also be informative to see whether you can see anything is picked up by sudo tcpdump -i eth0 proto ipv6 (replace eth0 by the name of your default ipv4 interface). You'd expect to see the tunnelled traffic.
    – richvdh
    Commented Mar 5, 2012 at 9:46

I have configured this option at home too, with Hurricane. It works! but pay attention the following:

1 - I am using ubuntu 11.10

2 - I disabled my manual configuration and bridge configuration at /etc/network/interfaces and set eth0 just like " auto etho / iface eth0 inet dhcp"

3 - I have followed the configurations video at Hurricane Website http://ipv6.he.net/presentations.php. The video named "Tunnelbroker.net Tour & Tunnel Creation"

4 - Unless you set the Public Ip of your ISP ( because I don't have a static puclic IP), you need to set YOUR end point IP (LAN) in this parameter "endpoint", for example.... # ifconfig

eth0 Link encap:Ethernet  Endereço de HW f4:6d:04:d0:db:e3  
     inet end.:  Bcast:  Masc:

So do: "endpoint"

I have confgured my ipv6 address like route2...copy the comands and paste in the shell, no in the interfaces configuration file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .