1

My touchpad is not working properly on Ubuntu 18. I can left-click on buttons etc. but the cursor won't move.

This is the result of my xinput:

⎡ Virtual core pointer                     id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SYNA7DB5:00 06CB:7DB7 Touchpad            id=12   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=15   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=17   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ HD WebCam: HD WebCam                      id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                          id=14   [slave  keyboard (3)]
    ↳ Logitech USB Receiver                     id=16   [slave  keyboard (3)]
0

Press f2 on startup go into bios, go to "main", go down to "touchpad" and hit enter, change from "advanced" to "basic" hit f10 to save and reboot. Seems to be a setting that changes itself if you let your battery die, like legacy boot mode.

0

Check whether xserver-xorg-input-synaptics is install or not?

apt list --installed | grep xserver-xorg-input-synaptics   

If it is missing, install it by invoking this command

sudo apt update  
sudo apt install xserver-xorg-input-synaptics  

Now, reboot or logout your pc, it should fix your problem. And if you want tweak your mouse emulation configuration use gnome-tweak.

  • xserver-xorg-input-synaptics is installed – Nick Dec 1 '18 at 18:40
  • @Nick It seems like Matthew was right you have to change your BIOS setting. If someone's answer worked for you should accept that answer and upvote that . Think of, it like reward for him. – finn Dec 1 '18 at 18:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.