2

I found a similar question here, but the answers did not solve my problem. KDE connect can not browse my android phone

I know how to use a file server in my home. I am not looking for alternatives. Thank you.

When I run kdeinit5 from command and log errors while starting the browse function of kdeconnect I get the following:

kdeinit5: Shutting down running client.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/libexec/kf5/klauncher'
kdeinit5: Launched KLauncher, pid = 5595, result = 0
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kdeinit5: opened connection to :0
kdeinit5: Got EXT_EXEC '/usr/lib/x86_64-linux-gnu/libexec/kf5/kioexec' from launcher.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/libexec/kf5/kioexec'
command= "gnome-software --local-filename=%f" args= ("gnome-software --local-filename=%f", "kdeconnect://0000000000")
kdeinit5: Got EXEC_NEW '/usr/lib/x86_64-linux-gnu/qt5/plugins/kio_kdeconnect.so' from launcher.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/qt5/plugins/kio_kdeconnect.so'
kdeconnect.kio: Setting host:  "000000000"
kdeconnect.kio: Stat:  QUrl("kdeconnect://000000000")
Copying QUrl("kdeconnect://000000000")  to QUrl("file:///home/username/.cache/kioexec/krun/5603_0/")
kdeinit5: Got EXEC_NEW '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/file.so' from launcher.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/file.so'
Aborting aboutToFinish handling.
All files downloaded, will call slotRunApp shortly
No files downloaded -> exiting
kdeinit5: PID 5608 terminated.
kdeinit5: PID 5606 terminated.
kdeinit5: PID 5603 terminated.

I just started using kde plasma and I'm not sure if the gnome components are creating the issue. And if so which gnome components are the issue.

0

The kioexec error is now fixed in https://commits.kde.org/kio/3c18acc2229bf0824ee296791329ad74b6313ece

0

I'm currently still trying to work through the problem and have made some progress. I don't want to redefine the original post because some of the problem is solved. But I still need help.

I made a backup and did something dangerous. I apt-get removed gnome-shell, gnome-desktop3-data, and gdm. Followed that up with: sudo dpkg-reconfigure lightdm sudo apt-get autoremove

On reset desktop stuff was real messed up. Pressed CTL+ALT F2 sudo apt-get install gnome-shell, gnome-desktop3-data, gdm3 install of gdm3 automatically took me to dpkg configuration. I chose gdm3. Now, pressing the browse phone button works for kdeconnect.

But now I have the issue of when I select a storage folder on the phone I am greeted by an error saying, "The file or folder /run/user/1000/[long number]/storage/[long number]/ does not exist." Any idea what causes this issue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.