0

Like everyone who had this problem did There is a warning sign and it says "the error message was 'BrokenCount > 0',this usually means that you installed packages that have unmet dependencies."

And when I try to install something like vim.I get this

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
python-rosdep : Depends: python-rosdistro (>= 0.4.0) but it is not   going    to be installedvim : Depends: vim-common (= 2:7.4.052-1ubuntu3.1) but 2:7.4.052-1ubuntu3 is to be installed
Depends: vim-runtime (= 2:7.4.052-1ubuntu3.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

After I tried sudo apt-get -f install The terminal shows:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
   python-rosdistro python-rosdistro-modules
The following NEW packages will be installed:
   python-rosdistro python-rosdistro-modules
0 upgraded, 2 newly installed, 0 to remove and 389 not upgraded.
139 not fully installed or removed.
Need to get 0 B/37.0 kB of archives.
After this operation, 295 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
dpkg-deb: error: archive '/var/cache/apt/archives/python-rosdistro-  modules_0.7.0-1_all.deb' has premature member 'control.tar.xz' before 'control.tar.gz', giving up
dpkg: error processing archive /var/cache/apt/archives/python-rosdistro-modules_0.7.0-1_all.deb (--unpack):
subprocess dpkg-deb --control returned error exit status 2
dpkg-deb: error: archive '/var/cache/apt/archives/python-rosdistro_0.7.0-100_all.deb' has premature member 'control.tar.xz' before 'control.tar.gz', giving up
dpkg: error processing archive /var/cache/apt/archives/python-rosdistro_0.7.0-100_all.deb (--unpack):
subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
/var/cache/apt/archives/python-rosdistro-modules_0.7.0-1_all.deb
/var/cache/apt/archives/python-rosdistro_0.7.0-100_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

How could I solve this problem? Thanks for your time and hope to get advice.

0

It is reported in https://github.com/ros/rosdistro/issues/19481.

You need to install dpkg 1.17.5ubuntu5.8 by sudo apt-get install dpkg -y.

  • Thank you ! My problem has been solved. – MZW Nov 30 '18 at 15:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.