5

I want to play artifact on Ubuntu 18.04 but every time I try loading it says "failed to initialize Vulkan. Please make sure your driver and GPU support Vulkan."

I have an Intel SandyBridge mobile graphics card. When i enter sudo lshw -c video it says my driver is i915.

Could anyone tell me what driver I need to install or how to solve the issue?

Thanks!

3

There is no driver to install. Intel graphics only supports Vulkan on Ivybridge and newer chips. Sandybridge is too old.

3
  • Is it possible using mesa?
    – User
    Nov 29 '18 at 2:58
  • 1
    No. Mesa is just a provider of the GL APIs. If Vulkan was supported on your CPU, it would already be working.
    – dobey
    Nov 29 '18 at 21:00
  • 1
    Here is compatibility list: en.wikipedia.org/wiki/Vulkan_(API)#Compatibility (Skylake and up offer Vulkan 1.0 and 1.1 support, Ivy bridge to Broadwell support 1.0, Sandy bridge not supported)
    – abchk1234
    May 26 '19 at 15:55
2

On my Kaby Lake i had to run sudo apt install mesa-vulkan-drivers Inspired by the introduction directions here https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

tho i didn't even have this ppa installed. it just led me to check my current apt list *vulkan*

2
  • 1
    Worked like a charm! No ppa required.
    – Autodidact
    Nov 2 '19 at 5:24
  • 1
    Worked for me, intel UHD 620 Jan 19 at 6:34
0
 sudo apt-get install vulkan-tools vulkan-utils vulkan-validationlayers libvulkan1 libvulkan-dev mesa_vulkan-drivers

after that give the below command :

vulkaninfo 

intel HD 520 support vulkan on linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.