I'm new to linux with lubuntu on my Dell and found when a micro SD card inserted into the card reader it doesn't show up. I searched several site and found some info about bugs but can't seem to find a solution as this computer only has 32GB of EMMC storage.I also tried it in a windows machine and worked fine.

here is some info from my laptop from other posts / sites

dell3180:~$ lsusb
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 0bda:5520 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 0cf3:e005 Atheros Communications, Inc. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Tried sudo apt-get install exfat-utils and

dell3180:~$ sudo fdisk -l
Disk /dev/sda: 29.1 GiB, 31268536320 bytes, 61071360 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6c44e97a

Device     Boot    Start      End  Sectors  Size Id Type
/dev/sda1           2048 52932607 52930560 25.2G 83 Linux
/dev/sda2       52934654 61069311  8134658  3.9G  5 Extended
/dev/sda5       52934656 61069311  8134656  3.9G 82 Linux swap / Solaris

while card is inserted.

Any help is appreciated!


Further research revealed this is a known bug with the realtek rts_usb driver. I found a fix that works with my dell i3180 here:


I case someone else has this problem and is looking for a fix.

| improve this answer | |

I can confirm this problem too (I have a NB equipped with the same USB device), and the Github link from Mike Honeycutt's answer works fine (4.20.6-arch1-1-ARCH). My problem is that I have a 64GB exfat SD card for my camera, and both Win 10 and my camera can read the photo correctly while Arch cannot. Arch shows the folder correctly but it cannot show any photo under the folder, but if I change to a Transcend one, everything works fine.


sudo pacman -Syu linux-headers
cd /tmp
git clone https://github.com/asymingt/rts5139.git
cd rts5139
sudo make install
rmmod rtsx_usb_sdmmc rtsx_usb_ms rtsx_usb
insmod /lib/modules/4.20.6-arch1-1-ARCH/kernel/drivers/scsi/rts5139.ko

Ubuntu 18.04.1 LTS

On my machine the mkdir is required.

sudo apt-get install linux-headers-generic
cd /tmp
git clone https://github.com/asymingt/rts5139.git
cd rts5139
sudo mkdir -p /lib/modules/4.15.0-45-generic/kernel/drivers/scsi
sudo make install
sudo rmmod rtsx_usb_sdmmc rtsx_usb_ms rtsx_usb
sudo insmod /lib/modules/4.15.0-45-generic/kernel/drivers/scsi/rts5139.ko

Note 1: the ko file path depends on your kernel version.

Note 2: This will not persist after rebooting, but I think something bad will happen if following the Github page without using DKMS.

| improve this answer | |
  • 1
    Sadly, both the commands and directory structure are different in Ubuntu. Would you care to take a stab at revising your answer to fit in this distribution? – Charles Green Feb 8 '19 at 16:02

It helps me for SD, but after adding that line into grub


My Dell Inspiron 3180 freezes after the opening the LID (waking up from suspend mode) - blacklisting rtsx_usb is the point

$ uname -a Linux small-note 4.15.0-58-generic #64-Ubuntu SMP Tue Aug 6 11:12:41 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.