0

I just installed the Eclipse IDE, but there seems to be an error when I execute Eclipse.exe.

Here's the log file:

!SESSION Wed Nov 28 18:42:12 IST 2018 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2018-11-28 18:42:12.757
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
    at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

what should I do?

  • I don't see an error. Why do you execute Eclipse.exe ? Are you using Windows? Start with eclipse – abu_bua Nov 28 '18 at 16:20
  • What version of Eclipse? What version of Java? – greg-449 Nov 29 '18 at 8:47
  • Sorry for the late reply. I'm using Ubuntu 18.04. I downloaded eclipse using the "sudo apt-get eclipse" command. I think I used the wrong phrase when I wrote I "execute eclipse". I meant that I simply launched the eclipse application. But there does seem to be an error. – Apekshik Panigrahi Dec 1 '18 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.