2

I am creating a cross platform mobile application using cordova. i am running the command

cordova run android 

and getting below error. The screen just hangs also.

CPU acceleration status: /dev/kvm is not found: VT disabled in BIOS or KVM kernel module not loaded

I entered below command to see if kvm is supported and it does as per below output but the below output is also suggesting to enable Virtualization from BIOS.

$ sudo /usr/sbin/kvm-ok

INFO: /dev/kvm does not exist
HINT:   sudo modprobe kvm_intel
INFO: Your CPU supports KVM extensions
INFO: KVM (vmx) is disabled by your BIOS
HINT: Enter your BIOS setup and enable Virtualization Technology (VT),
      and then hard poweroff/poweron your system
KVM acceleration can NOT be used

I tried entering the BIOS using F2 command but got below screen where I can't see an option to enable virtualization.

BIOS screen

Then I tried with ESC key and got below screens. Here also I didn't see any option to enable virtualization.

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

Below is my CPU information

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 60
Model name:            Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
Stepping:              3
CPU MHz:               2610.359
CPU max MHz:           3600.0000
CPU min MHz:           800.0000
BogoMIPS:              6385.18
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              6144K
NUMA node0 CPU(s):     0-3
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm cpuid_fault epb invpcid_single pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts flush_l1d

Can someone tell me where I can find the option to enable virtualization in Ubuntu 16.04 LTS?

  • Please update your question by posting some specs about your PC ( information about CPU). And did you check the Advanced section in the BIOS settings? – singrium Nov 28 '18 at 12:53
  • 1
    yes, i checked Advanced setting but didn't see any useful option. updated my question to include CPU info for your information. – Sanjay Salunkhe Nov 28 '18 at 13:50
  • 1
    I am not sure, but I think the virtualization options are in security section. Check this video it is in French, but you only need to watch the steps. – singrium Nov 28 '18 at 14:00
  • @singrium thanks... its in security .. you are right... worked for me – Sanjay Salunkhe Nov 28 '18 at 14:22
  • Glad it helped. I will post an answer detailing the steps of enabling the virtualization so that others with the same problem can find it. – singrium Nov 28 '18 at 14:24
4

As we discussed in the comments, the Virtualization option is in the security section of the BIOS menu.
After you open the BIOS, scroll to the security options and enable the virtualization technology.
Then save and exit. After restarting your PC, the virtualization should be enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.