0

So I'm trying to get my Dualshock3 to work on my Ubuntu 18.10

I've plugged it and tried this command on the terminal :

sudo xboxdrv --detach-kernel-driver

I can see that the events are detected, but when I tried to play with it, nothing was working.

I've installed Antimicro, I can see that a controller is detected, but it doesn't detect any event. For example when I try to do a quick configuration, I keep pressing buttons but nothing happens.

Does anyone have an idea?

Thanks!

  • xboxdrv is outdated and shouldn't be needed anymore. The hid_sony driver handles DS3/DS4 quite well without any setup. Which Ubuntu and kernel version do you use? – danzel Nov 28 '18 at 14:27
  • hi @danzel I'm using Ubuntu 18.10 with Linux 4.18.0-11-generic I'm gonna have a look on the hid_sony driver, thanks! – Kevin J Nov 29 '18 at 11:03
  • The hid_sony kernel module should be installed by default. Have you pressed the PS button when the LEDs started blinking? – danzel Nov 29 '18 at 13:42
  • yes I did @danzel , after more research I've seen that a lot of people had this issue after upgrading to 18.10, perhaps it's an Ubuntu bug... – Kevin J Nov 29 '18 at 16:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.