I have problems with installing the gsl package. Running Xubuntu 18.04, octave 4.4.1.

Using -forge, the installation process stalls with the following message:

 pkg install -forge gsl
 configure: error: gslcblas library not found

I have installed via synaptic: libgslcblas0, libgsl-dev, libgsl23

Can anybody give me instructions on what to do now?

Iasked this yesterday on the octave mail list, but got only the answer to install gslclbas, which is already installed.

EDIT: Thanks for your advice N0rbert, but sorry the advice installing liboctave-dev did not work for me.

I get

**pkg install -forge gsl

configure: error: gslcblas library not found

checking for mkoctfile... /app/bin/mkoctfile-4.4.1

checking for octave... /app/bin/octave-4.4.1

checking for Octave's canonical_host_type... x86_64-pc-linux-gnu

checking for Octave's include directory... /app/include/octave-4.4.1/octave

checking whether the C++ compiler works... yes

checking for C++ compiler default output file name... a.out

checking for suffix of executables...

checking whether we are cross compiling... no

checking for suffix of object files... o

checking whether we are using the GNU C++ compiler... yes

checking whether g++ accepts -g... yes

checking how to run the C++ preprocessor... g++ -E

checking for grep that handles long lines and -e... /usr/bin/grep

checking for egrep... /usr/bin/grep -E

checking for ANSI C header files... yes

checking for sys/types.h... yes

checking for sys/stat.h... yes

checking for stdlib.h... yes

checking for string.h... yes

checking for memory.h... yes

checking for strings.h... yes

checking for inttypes.h... yes

checking for stdint.h... yes

checking for unistd.h... yes

checking ov-scalar.h usability... yes

checking ov-scalar.h presence... yes

checking for ov-scalar.h... yes

checking for cos in -lm... yes

checking for cblas_dgemm in -lgslcblas... no

pkg: error running the configure script for gsl.

error: called from

configure_make at line 82 column 9

install at line 184 column 7

pkg at line 437 column 9**

Any other ideas?

I tried it with Octave 4.2.2. on another PC, same result.

Thanks.

Karl

You need to install Octave development package first with:

sudo apt-get install liboctave-dev

With standard Octave 4.2.2 from official Ubuntu repositories this results in successful installation of internal gsl package.

>> pkg load gsl
>> gsl_sf_sinc(0)
ans =  1

For your information: Ubuntu provides octave-gsl package ver. 2.1.0-3, while Octave Forge provides ver. 2.1.1 - NEWS file contains note:

===============================================================================  
gsl-2.1.1  
===============================================================================  

** Octave 4.4 compatibility fixes (remove deprecation warnings)  

So you can use Octave from repositories.

  • @ N0rbert sorry that does not work for me. See my edit above. Still the same error message. – Karl Nov 29 at 7:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.