1

I tried to follow the instructions on this post, but it did not work for me, what I'm doing wrong? Here's my local file in /etc/default/locale

#  File generated by update-locale
LANG="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
2
  • 1
    Did you log out and log back in?
    – Jos
    Nov 28, 2018 at 9:08
  • Yes, I did, to double check, I even turned off the pc then back on, still the same.
    – Michael
    Nov 29, 2018 at 11:25

1 Answer 1

0
  • To find out, which locale file is Ubuntu using right now:

    locale

The output in my case:

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

That means, that my locale is en_US, settings for this locale are saved in file en_us in /usr/share/i18n/locales/ directory.

  • Make a backup of the file:
    sudo cp /usr/share/i18n/locales/en_US /usr/share/i18n/locales/en_US.bak

  • Edit the en_US file and change first_weekday from 1 (Sunday) to 2
    (Monday):
    sudo nano /usr/share/i18n/locales/en_US

  • Then generate locale files:
    sudo locale-gen

  • Login and logout to apply changes:
    gnome-session-quit

Credits: Change first day of week to Monday on Ubuntu GNOME calendar

2
  • Thanks, this solution works. Just curious, why by changing to LC_TIME="en_GB.UTF-8" did not work? It seems overwritten somehow.
    – Michael
    Nov 29, 2018 at 11:40
  • Glad it worked for you. I am not sure but I think the configuration file has been changed: in the old version, just changing LC_TIME="en_GB.UTF-8" would do the thing, but in the new version, the structure of the file has been changed so , may be, changing that line would not have an effect.
    – singrium
    Nov 29, 2018 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.