4

I did the basic install, but when I run it, I get:

Build environment error! A required application is missing and modconfig cannot continue. xzCheck the log for more details.

What does that mean and what should I do?

0

2 Answers 2

11

Run the following commands before/after installing vmware:

sudo apt-get install gcc
sudo apt-get install make
sudo apt-get update

Let me know if you have any other errors we will sort it out.

2
  • 3
    Installing gcc and make solved this exact error for me when installing VMware Workstation 15 on Ubuntu 18.04.1 LTS. Feb 8, 2019 at 13:42
  • Had this issue on Ubuntu 20.04 and Vmware complained about gcc not being installed, but it forgot to mention make. Thx.
    – Kjetil S.
    Jun 5 at 12:46
3

As suggested in https://kb.vmware.com/s/article/1002411

vmware-modconfig --console --install-all

worked on kubuntu 18.04 with VMware Workstation Player 15.5.0

Installing gcc and make did not solve the error, or at least were not sufficient.

1
  • solved it for me on Ubuntu 20.04 together with installing gcc and make.
    – sevku
    May 4, 2020 at 5:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.