1

I'm using an Acer Switch 5 (a compact laptop with detachable keyboard) with Ubuntu 18.10 + latest updates. Generally the experience is great, but there is a frustrating niggle:

When I close the keyboard up against the screen (lid close) the laptop sleeps as expected. But when I open it again, the keyboard and it's built-in touchpad are dead (although the laptop otherwise wakes as expected). To make them work again, I must detach the keyboard and re-attach it. Very cumbersome.

Interesting side note: if I manually put the laptop to sleep, either by pressing the sleep/power button or by selecting suspend/sleep from the power menu and THEN close the lid, when I open the keyboard again, it wakes the laptop and everything works! Hmm.

This is the first time I have tried Linux on the device -- so it's not a regression (i.e. I have never known it to work in the past).

So: do you smart people here know if there is a different sleep action happening when I select suspend/sleep from the menu vs just close the lid? Or do you think there is some confusing hardware/firmware magic happening when the keyboard closes against the powered on laptop?

My current work around is to manually sleep the laptop myself each time before closing my lid. But that is not ... nice.

Thanks for any input!

  • Regardless whether there is a workaround or not, this looks to me like a kernel bug. Specifically, in the Linux Input Subsystem. If you like, you can report it. See https://kernel.org. – Jos Nov 27 '18 at 11:03
1

I have felt your pain before and I'm going to assume you haven't modified your GRUB file yet. There are various options or combinations of options that seem to work, so you may have to experiment. This has been a recurring theme on my Toshiba L850D and here is what solved it for me:

In a terminal open GRUB: sudo nano /etc/default/grub

Now find the line that starts with GRUB_CMDLINE_LINUX_DEFAULT="

and replace it with

GRUB_CMDLINE_LINUX_DEFAULT="atkbd.reset i8042.reset i8042.nomux quiet splash"

Save and exit Ctrl+O and Ctrl+X then update GRUB.

sudo update-grub

Reboot and cross your fingers! You may not need i8042.nomux as that is apparently for very old hardware, but I experienced intermittent results without it.

If that doesn't work you can find other options (like dumbkbd) and more detail in this thread:

Ubuntu 17.04 keyboard not responding after suspend

Edit: In case you're wondering I meant to add that my experience with the lid versus the power button was the same.

Hope that helps.

  • Thanks Mark! I tried your suggestions, including the ones in the linked post but they were not effective sadly -- the problem remains. – Michael Nov 27 '18 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.