0

I have working windows 10 on this fake raid 0. Windows shows raid as a Intel Raid 0 Volume

I want to install ubunt (tried other flavours of linux but no luck too) and ubunt doesn't see my fake raid.

I've installed mdadm and run mdadm --assemble --scan and i get error: no arrays found in config file or automatically.

Also lsblk gives me only my pendrive for live linux.

lspci -k shows that the ahci driver is working but nothing is detected in pcies slots

My problem is similar to this but i'm runing intel :(

My spec:

cpu: i7 6700k | ram: 2x8gb | disks: 2x samsung 970 evo m.2 | mobo: asrock z270 k4

I trying to install linux for 2 days and i realy need help please help me ;)

  • RAID 0 not really recommended. It was used with HDD for increased speed as alternating tracks were on different drives. But only for gamers or users compiling software where system was backed up daily or had no data. If one drive fails system neither drive works. You can only break your RAID by reinstalling Windows to one drive. See RAID 0: en.wikipedia.org/wiki/RAID If you really want RAID 0, install Ubuntu onto another drive. – oldfred Nov 26 '18 at 21:16
  • a bit late but have you tried to follow along this: medium.com/@pmarrapese/… ? I am in a similar situation. for the moment i keep using windows and subsystem linux until I have time for this venture. – KIC Jan 28 at 7:40
0

I'm wondering if spliting this disks and formating they to ext4 seperatly, making raid again and installing ubuntu first will help?

And yeah at this point i'm very desperated to get this working, event if i'll have to install win on fresh.

  • This is really a comment, not an answer. Anyway, I think that you'll have to backup Windows (or fresh reinstall it later), split the RAID, change the BIOS setting, init one drive as NTFS and restore/reinstall Windows, and then init the 2nd drive as EXT4 and install Ubuntu there. – heynnema Nov 28 '18 at 14:44
  • yeah since i'm experiencing a wired lost in performance on this drives (since ther're about half full, what shouldn't happend before 85% full) i'm going to spilt the drives in next weekend perfomance: drive.google.com/file/d/1b9PIKscebkWDq0akcw-5gweZsH_eEFY7/… btw. do you know what could cause that low speed on fresh windwos seq was above 6k MB/s on both write and read – Aloess Nov 29 '18 at 15:40
  • You may have a problem with too much Windows stuff, 'cause after you split the RAID, you'll have half the space available. The slowness could be do to fragmentation, although with only 50% used, I wouldn't think so... it all depends on how the data files were created. You may also with to check if there's a firmware update for the Samsung SSD's. Also, I might create a separate NTFS partition that can share data between Windows and Ubuntu. – heynnema Nov 29 '18 at 16:14
  • firmware is definitly outdated like my bios but form producent site is only mention ram compability upgrade what i don't have any problem so i don't want to risk for only higer number in bios, i can't upgrade ssd firmware when i have raid :C – Aloess Nov 29 '18 at 16:28
  • @heynnema i think with a reputation of one you are not even able to comment :-) mdadm should actually be capable of using intel fake raid (RST) – KIC Jan 28 at 7:50
0

Of course, you've figured out that Ubuntu Desktop does't like the RAID.

The common way to fix this is to change RAID to AHCI in the BIOS... but then it looks like you've got a real RAID using 2xSamsung... so you may have to split the RAID to do this... depends on your actual hardware configuration.

See my procedure below, and see if any of it can be applied to your configuration...


Some folks have found the 2nd choice that I provide easier to do...

Make sure to have a backup of your important Windows files!

You've got a single/multiple SSD set up in RAID mode, and the Ubuntu installer won't recognize your SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot.

Choice #1: Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

  • Boot to Windows with your current SATA controller configuration
  • Open Device Manager
  • Expand Storage Controllers and identify the Intel SATA RAID Controller
  • View properties of the identified controller
  • On the Driver tab, click the Update driver… button
  • Browse my computer…, Let me pick…
  • Uncheck Show compatible hardware
  • Select Microsoft as manufacturer
  • Select Microsoft Storage Spaces Controller as model3
  • Accept that Windows cannot confirm that this driver is compatible
  • Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
  • Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

Choice #2: See http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
  • Click the Start Button and type cmd
  • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
  • 1
    I already tried this but changing mode in bios from raid to ahci t is splitting disks for real, windows with changed mode is not booting and ubunt sees two drives with damaged data (from there i know it's spliting disk, also in bios raid disappers) – Aloess Nov 26 '18 at 19:25
  • @Aloess You may need to split the RAID first, then change to AHCI. You may have to backup/restore the RAID to a single AHCI SSD. How do you feel about Windows on one Samsung, and Ubuntu on the other? – heynnema Nov 26 '18 at 19:28
  • i'm not realy happy about that becouse i bought this drives special for raid 0. On facebook someone told me to try to split both drives to 2 partitions and try raid 0 in both systems is it worth it? – Aloess Nov 26 '18 at 19:33
  • I think that you'll have the same problem. I'm no expert here, so we'll need to let someone else jump in with better advice. – heynnema Nov 26 '18 at 19:35
  • any ways thanks for help :) i think i will give up and try this suggested option if it will not work i will split the drives for windows and linux :C – Aloess Nov 26 '18 at 19:39

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.