I've had a power outage recently while I was working in Blender. After reboot I have weird system behavior, it hangs when I work in Blender or scroll sites with Firefox. For instance, I left PC on over night with Blender, Firefox and task manager opened and when I tried to Alt+Tab to Blender in the morning and I saw that it's hanging. I tried to close Blender window with x button and via task manager (stop process) but it didn't help and caused task manager to hang. I opened terminal, but it also hanged the second it opened. I tried open TTY (Ctrl+Alt+F1) and it opened and asked me to log in, but after I entered my username - it didn't offered me to enter password, cursor was just blinking below my username. I tried to connect to PC via ssh, but it also stuck at connecting as if PC was unresponsive. I tried Alt+SysRq+n, Alt+SysRq+f but the desktop remained stuck. I used REISUB to soft reboot. I can't tell if there is any pattern of what causes system hangs. I've already tried boot with Ubuntu LiveUSB and used fsck on my nvme SSD, but it found no errors. How can I define what causes hangs? And what logs should I check?

My specs are:

  • Xubuntu 18.04
  • AMD Ryzen 5 2600X
  • AMD Radeon 580rx
  • Corsair 2x8 GB RAM
  • Nvme SSD Adata 128 GB

Okay,after all possible checks, it seems to be a faulty nvme SSD. Never had such problems with SATA SSDs and HDDs, I even unplugged them during writing process and nothing dramatic happened. It seems that PCI-E SSDs are more sensible to power outage. Although SMART shows there are no errors on nvme SSD (that's why I was mislead and thought the issue might be somwhere else), I am unable to write anything on it, and reading from it turns into lagfest that freezes system completely. Back to good old SATA drives.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.