2

While trying to upgrade from Ubuntu 18.04 to 18.10 I get this error:

An unresolvable problem occurred while calculating the upgrade. 

This can be caused by: 
* Upgrading to a pre-release version of Ubuntu 
* Running the current pre-release version of Ubuntu 
* Unofficial software packages not provided by Ubuntu 

Googling it led me to a post that suggested running grep Broken /var/log/dist-upgrade/apt.log and the output of that is below. What do I do with those packages? they seem to be video related, won't removing them make my video card stop working?

Broken libtinyxml2-6a:amd64 Conflicts on libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken fwupdate-signed:amd64 Depends on fwupdate:amd64 < 10-3 -> 12-3ubuntu2 @ii umU > (= 10-3)
Broken libdns1100:amd64 Depends on libisc169:amd64 < 1:9.11.3+dfsg-1ubuntu1.3 -> 1:9.11.4+dfsg-3ubuntu5 @ii umU > (= 1:9.11.3+dfsg-1ubuntu1.3)
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.1 -> 3.30.1-1build1 @ii umU > (= 3.28.5-0ubuntu0.18.04.1)
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 18.1.99+git1809201934.451fe9~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:18.1.0+git1809141934.80514b~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.15+git1807201019.ac8f7b~oibaf~b @ii mR >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 18.1.99+git1809201934.451fe9~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:18.1.0+git1809141934.80514b~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.15+git1807201019.ac8f7b~oibaf~b @ii mR >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 18.1.99+git1809201934.451fe9~oibaf~b @ii mR >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 18.1.99+git1809201934.451fe9~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:18.1.0+git1809141934.80514b~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.15+git1807201019.ac8f7b~oibaf~b @ii mR >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 18.1.99+git1809201934.451fe9~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:18.1.0+git1809141934.80514b~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.15+git1807201019.ac8f7b~oibaf~b @ii mR >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-radeon:amd64 < 1:18.1.0+git1809141934.80514b~oibaf~b @ii gR >
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 18.1.99+git1809201934.451fe9~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:18.1.0+git1809141934.80514b~oibaf~b @ii mR >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.15+git1807201019.ac8f7b~oibaf~b @ii mR >
3
  • 2
    The error message provides good guidance - read it again. Best practice is to uninstall ALL packages from PPAs and other non-Ubuntu sources - restore your system to as close to stock condition as possible before starting a release-upgrade. – user535733 Nov 26 '18 at 2:07
  • But if I uninstall my video drivers, is it at least going to work enough for me to reinstall them after the upgrade? – casolorz Nov 26 '18 at 14:25
  • Went ahead and removed them and the update worked, and nothing seems to be broken (except for slack). – casolorz Nov 26 '18 at 23:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.