0

I bought a new Dell laptop with two separate hard disks. One 128GB SSD with pre-installed Windows 10 and one 1Tb HDD (let's say dev/sdb). I'm trying to install Ubuntu 18.04 in a partition dev/sdb2. I'm trying to find the SSD efi partition but the wizard doesn't show it up. I run os-prober but I get no results.

Also followed this guide: Dual Boot Windows 10 and Linux Ubuntu on Separate Hard Drives with no success as no GRUB OS choice is shown.

Any idea on how to get Ubuntu to detect the SSD?

1

Check in your BIOS for how the disks are setup. They're probably set to RAID. Ubuntu won't install unless you change this.

You don't need to reinstall Windows...

Some folks have found the 2nd choice that I provide easier to do...

Make sure to have a backup of your important Windows files!

You've got a single SSD set up in RAID mode, and the Ubuntu installer won't recognize your SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot.

Choice #1: Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

  • Boot to Windows with your current SATA controller configuration
  • Open Device Manager
  • Expand Storage Controllers and identify the Intel SATA RAID Controller
  • View properties of the identified controller
  • On the Driver tab, click the Update driver… button
  • Browse my computer…, Let me pick…
  • Uncheck Show compatible hardware
  • Select Microsoft as manufacturer
  • Select Microsoft Storage Spaces Controller as model3
  • Accept that Windows cannot confirm that this driver is compatible
  • Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
  • Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

Choice #2: See http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
  • Click the Start Button and type cmd
  • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
  • Thank you very much for your quick response! I'll give it a try to the second choice and soon I will provide any feedback of my success or failure. Kudos for your help! – Pantelis Gramvousakis Nov 26 '18 at 20:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.