0

This question already has an answer here:

I'm running 18.04, and I'm attempting to install Wine, which has an unsigned repository. I tried bypassing this by using the --allow-unauthenticated flag, but I get an error

$ sudo apt-add-repository https:/dl.winehq.org/wine-builds/ubuntu/ --allow-unauthenticated
Usage: apt-add-repository <sourceline>

apt-add-repository is a script for adding apt sources.list entries.
It can be used to add any repository and also provides a shorthand
syntax for adding a Launchpad PPA (Personal Package Archive)
repository.

<sourceline> - The apt repository source line to add. This is one of:
  a complete apt line in quotes,
  a repo url and areas in quotes (areas defaults to 'main')
  a PPA shortcut.
  a distro component

  Examples:
    apt-add-repository 'deb http://myserver/path/to/repo stable myrepo'
    apt-add-repository 'http://myserver/path/to/repo myrepo'
    apt-add-repository 'https://packages.medibuntu.org free non-free'
    apt-add-repository http://extras.ubuntu.com/ubuntu
    apt-add-repository ppa:user/repository
    apt-add-repository ppa:user/distro/repository
    apt-add-repository multiverse

If --remove is given the tool will remove the given sourceline from your
sources.list

apt-add-repository: error: no such option: --allow-unauthenticated

I've seen other users on the site with the same version of Ubuntu claim this option works. What am I doing wrong here?

marked as duplicate by N0rbert, Eric Carvalho, abu_bua, Fabby, Thomas Dec 1 '18 at 9:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4

You may use the option --allow-unauthenticated with the commands apt or apt-get but not with the command add-apt-repository.

Please take a look at https://wiki.winehq.org/Ubuntu where it is very well explained how to add the desired repository.

If you have previously installed a Wine package from another repository, please remove it and any packages that depend on it (e.g., wine-mono, wine-gecko, winetricks) before attempting to install the WineHQ packages, as they may cause dependency conflicts.

If your system is 64 bit, enable 32 bit architecture (if you haven't already):

sudo dpkg --add-architecture i386 

Then run the following commands:

wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add Release.key
sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/

Now you need to update the cache with

sudo apt update

And finally install with

sudo apt-get install --install-recommends winehq-stable
  • Sorry to double dip, but how do I add the repository then? – user189728 Nov 25 '18 at 19:24
  • Doesn't work: pastebin.com/tCrteLMb, I tried apt-update as well and got a similar result. – user189728 Nov 25 '18 at 19:41
  • Please see my edit, now that I know which repository you want to add. – mook765 Nov 25 '18 at 19:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.