2

the linux uprising ppa is currently forcing version 11 of java on us.

sudo add-apt-repository ppa:linuxuprising/java

that's nice I like modern and being up to speed, but I have an app that'll only run with java 10.

webUpD8 stopped after 9 and linux uprising started at 10 and that worked (apparently..., I personally never got to test it) until they released 11 and now when you type :

sudo apt install oracle-java10-installer

you get :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package oracle-java10-installer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'oracle-java10-installer' has no installation candidate

only typing :

sudo apt install oracle-java11-installer 

will work. that's the package that's being referenced above.

clearly something was done that was a little sloppy :

what are my options?

2
  • 2
    Java 10 is no longer supported. It reached EOL the moment when 11 was released in September 2018. That is why it is no longer really available and why you should not be using it anyway. Java 11 is supposed to be fully backwards-compatible, I believe, so anything running under 10 should work just fine with 11. See the table on oracle.com/technetwork/java/eol-135779.html for reference about the EOL dates. – Byte Commander Nov 25 '18 at 14:17
  • i tried running sudo apt install openjdk-10-jdk but even that defaulted to installing oracle jdk 11. is there really no trick I can pull? – tatsu Nov 25 '18 at 15:54
2

EDIT: If you have successfully installed openjdk-10-jdk package, than You just need to switch default jdk version using 'update-java-alternatives' command (as described here).


You could manually install openjdk (instead of using apt).

For example, openjdk 10 is available to download at jdk.java.net or adoptopenjdk.net.

Installation instructions are available at docs.oracle.com.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.