Currently using Kubuntu 18.04. I am trying to set up deja-dup to backup my files to my Google Drive. I have already added my google accounts and can access my files on Google Drive through dolphin.

But I can't seem to select GDrive as my backup destination in deja-dup. Below is the error message I get.



Configure Deja-Dup for automatic backups to remote Google Drive

  1. Add Google account
  2. Mount Google Drive (automatically on login)
    • KDE: follow above instructions
    • Gnome: [Apps Menu] > Settings > Startup Applications > Add
      1. Name: Mount Google Drive
      2. Command: sh -c 'gio mount google-drive://<username>@gmail.com'
  3. Configure Deja-Dup for automatic backups
    Open Deja-Dup, select your Google Drive account in Storage Location, name the folder, and enable automatic backups.
| improve this answer | |
  • 1
    I followed the kde instructions but deja-dup is still not being able to identify the online account. I read somewhere that deja-dup relies on gnome-online-accounts. But gnome-control-center is not working in kde neon – clyton dantis Sep 20 '19 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.