0

If I run meson -v it reports back as 0.44.

cxf@PC:~$ meson -v
0.44.0
cxf@PC:~$ which meson
/usr/local/bin/meson

I think I did something when compiling DXVK on 17.04/17.10/18.04 but I can't remember what. I upgraded to 18.10 from 18.04. How can I fix this?

  • 1
    Uninstall meson with apt and use meson from pip3. – mja Nov 25 '18 at 9:39
  • That doesn't solve anything and it still returns 0.44. Ubuntu 18.10's repo has meson 0.47 so that ain't the problem. – Ubuntuthrow Nov 25 '18 at 21:32
  • Give me dpkg -l '*meson*' output? – mja Nov 26 '18 at 3:19
  • `` dpkg -l 'meson' Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name Version Architecture Description +++-================-=============-=============-====================================== un meson <none> <none> (no description available) `` – Ubuntuthrow Nov 27 '18 at 0:44
  • It's weird! dpkg claimed that meson is uninstalled. Why would you have meson v0.44.0? – mja Nov 27 '18 at 0:57
0

Installing meson via pip3 install meson and rebooting gives me meson 0.48.2. Still no clue why it was reporting 0.44 when the apt version (0.47) was installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.