24

My open file dialog is defaulting to showing hidden files, I have to press Ctrl-H to get to the files I want, but this is not saved across instances of the dialog.

I can't find a settings panel to change this behaviour, including Nautilus preferences, nor a key in the configuration editor. Is there a way to have the open file dialog default to not show hidden files?

22

Edit the file

~/.config/gtk-2.0/gtkfilechooser.ini

There is a line

ShowHidden=true

change to

ShowHidden=false

Save and close.

Worked for me!

5
  • Thanks I had the same problem and this fixed it for me because changing settings in Nautilus file browser doesn't affect File Open/Save dialog window
    – MichaelDD
    Apr 6 '16 at 12:45
  • This did not work for me in Mozilla Firefox. This is what helps: right-click in the folder view of a dialog box and uncheck "Show Hidden Files". Sep 19 '18 at 9:22
  • 2
    For GTK 3, run this: gsettings set org.gtk.Settings.FileChooser show-hidden false Jul 10 '20 at 14:03
  • @AlexanderPozdneev you should post that as an answer so I can upvote. That was the only solution that worked for me! May 14 at 17:09
  • @LordElrond, thanks for the hint. I edited the answer. Once it is approved, that will be OK to delete my comment. May 16 at 12:15
13

You may have checked showing hidden files in preferences. In Nautilus (file browser) click Edit>Preferences and in Views tab if Show hidden files and backup files is ticked, remove the tick.

Hidden Files Setting

2
  • 2
    That was the first place I looked. Show hidden files and backup files is and has been unchecked. Mar 3 '12 at 4:32
  • +1 to Erich Youngren's comment. This answer pertains to Nautilus file manager, not the file selector dialogue.
    – elzilrac
    Sep 30 '14 at 20:58
4

To fix this in 13.04, I had to right click on the dialog and uncheck "Show Hidden Files"

0

In Ubuntu 14.10 you have to click on the gear button on the right of the toolbar and the click on Preferences -> View and remove the tick on Show hidden and backup files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.