2

I have noticed that in my Ubuntu 18.10/GNOME 3.30.1 it is missing all the small icons that should be on the left side of the application submenus.

This problem occurs in all installed software. Even those that are installed together with Ubuntu. The following screenshot shows a submenu where the icons are missing.

enter image description here

Applications work flawlessly, but the absence of these little icons slows the understanding of complex application functions a bit. Any help?

  • 1
    This ask.fedoraproject.org/en/question/23116/… may help you, but essentally such icons are deprecated in Gnome 3. – vanadium Nov 24 '18 at 19:15
  • Thank you! Problem solved thanks to your post! – Fábio Sousa Nov 26 '18 at 0:18
  • @Fabro, would be good if you write an answer and also accept it for future reference of this site of readers with the same problem. It is perfectly fine to accept your own answer. – vanadium Nov 26 '18 at 9:18
1

Thanks to @vanadium, I was able to fix this problem by following the instructions as follows.

From the accepted answer in this link:

Both gtk-menu-image and gtk-button-images were deprecated and ignored, after that they made them deprecated but not ignored: https://git.gnome.org/browse/gtk+/commit/?id=627a03683f5f41efbfc86cc0f10e1b7c11e9bb25 https://git.gnome.org/browse/gtk+/commit/?id=c46aca463a9d66cf402ec8c3f9f2e2efc98c42ca

the problem is the gsettings keys (org.gnome.desktop.interface buttons-have-icons and menus-have-icons) are gone so I don't see a way to set them...

However it seems you can set the relevant GtkSettings via the gnome-settings-daemon xsettings plguin: open dconf-editor -> org.gnome.settings-daemon.plugins.xsettings and change the overrides key from:

{}

to:

{'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1>}

usually the change is instantaneous (e.g. in gimp), but some apps need to be restarted (e.g. firefox).

Or just use gsettings:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1>}"

but note that this method overwrites the current value of that key; one obvious caveat is if you've previously enabled pasting with the middle click from gnome-tweak-tool -> "keyboard and mouse", you'll need to re-set it there again (unlike the above gsettings command, gnome-tweak-tool "adds" new values to the overrides key and doesn't blindly overwrite it).

Edit: testing recently, it seems now that toggling either of these settings in gnome-tweak-tool remove the custom values added above:

  • Top Bar -> "show application menu"
  • Keyboard and mouse -> middle-click paste so if you toggle any of those settings you'll have to re-add the 'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1> bits.
0

These icons are deprecated. Fortunately, Kicad has an FAQ on how to enable them:

In the terminal, do:

gsettings set org.gnome.desktop.interface menus-have-icons true
gsettings set org.gnome.desktop.interface buttons-have-icons true

(To disable them again, run the same commands, but replace true with false.)

  • Thank you. I had tried these commands, but nothing changed. I think it's really a Gnome incompatibility with these icons. – Fábio Sousa Nov 26 '18 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.