12

I am trying to change my download location to a different internal hard drive. I get the following errors with both Chromium and Firefox:

enter image description here

My permissions are

drwx------  10 james james 4096 Oct 10 14:11 data

I also get the same error when trying to access my .Cryptomator directory, although I'm not sure if this is related.

I'm running Ubuntu 18.04. Thanks in advance.

EDIT: Output of mount | grep /media/james/data

/dev/sdc on /media/james/data type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
5
  • Please add the output of mount | grep /media/james/data to your question, we need to know which file system is used and how it is mounted.
    – mook765
    Nov 23, 2018 at 19:35
  • Do you use snaps or are firefox and chromium installed from official repositories?
    – mook765
    Nov 23, 2018 at 20:03
  • I installed via Ubuntu Software. My edit above seems to fix the issue. Nov 23, 2018 at 20:27
  • 2
    I can see in your screenshot that Chromium is installed as a snap. Congratulations, you found the culprit
    – mook765
    Nov 23, 2018 at 20:59
  • Please remove your edit from the question and post it as an answer instead. Mark your own as accepted, so you will get some reputation-points and probably some up-votes.
    – mook765
    Nov 28, 2018 at 10:19

2 Answers 2

17

I found an option under the permissions tab in Ubuntu Software that allows me to select "Read/write on removable storage devices" that seems to fix the problem.

enter image description here

3
  • This solution worked for me but the option mentioned above was already checked, I had to additionally check "Access USB hardware directly" for it to work on an external USB drive. Jul 5, 2020 at 17:22
  • I am on Lubuntu, is there a possibilty to solve this?
    – Timo
    Jul 20, 2020 at 18:02
  • Echoing that. I'm on Ubuntu 21.04. Not finding a Permissions tab in Ubuntu Software. Sep 2, 2021 at 23:17
0

Chromium like other browser might be running on another user profile which might be inclusive within your group.

Try setting the base read and write permissions on your group for your current drive so that you can access it and download files directly to it.

sudo chmod g+rw /media/james/data

You should at least be able to write to the drive to download files to it.

The drive is owned by your user james so you don't need to run a chown on the drive.

1
  • Thanks for the suggestion, but unfortunately no joy. I have set permissions to drwxrwxrwx and it still doesn't work. Nov 23, 2018 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.