1

Sound was working great on 14, but after upgrade to 16, there is not sound.

aplay seems to find the sound card:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****

card 0: PCH [HDA Intel PCH], device 0: ALC3235 Analog [ALC3235 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

Per advice on other threads, I reinstalled alsa-base and pulseaudio

On alsamixer (and gnome-alsamixer) the speaker is not muted.

On system settings-->audio, the "Play sound through" box is blank, and the mute box is not checked.

$ uname -r
4.4.0-139-generic

$ find  /lib/modules/$(uname -r) | grep snd

shows plenty of drivers

======== Here is what dmesg shows:

$ dmesg | grep -iE 'snd|hda'
[    5.291111] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops           i915_audio_component_bind_ops [i915_bpo])
[    5.375131] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC3235: line_outs=1 (0x16/0x0/0x0/0x0/0x0) type:line
[    5.375139] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=1 (0x14/0x0/0x0/0x0/0x0)
[    5.375142] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
[    5.375144] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    5.375146] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    5.375148] snd_hda_codec_realtek hdaudioC0D0:      Headphone Mic=0x18
[    5.375150] snd_hda_codec_realtek hdaudioC0D0:      Dock Mic=0x19
[    5.375153] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x1a
[    5.375155] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x13
[    5.423487] input: HDA Intel PCH Headphone Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
[    5.423550] input: HDA Intel PCH Dock Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
[    5.423604] input: HDA Intel PCH Dock Line Out as /devices/pci0000:00/0000:00:1f.3/sound/card0/input13
[    5.423658] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input14
[    5.423694] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input15
[    5.423729] input: HDA Intel PCH HDMI/DP,pcm=8 as /device/pci0000:000000:00:1f.3/sound/card0/input16
  • You may want to query dmesg, such as dmesg | grep -iE 'sdn|hda'. – mikewhatever Nov 23 '18 at 17:17
  • mikewhatever, thanks for the suggestion. I put the results of dmesg in the original question. (Grepping for snd rather than sdn) – Chris Nov 23 '18 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.