0

I have a fresh install of Ubuntu server 16.04, I have setup static ip I have set up ssh, I can connect from LAN fine, but whenever I try and connect externally I get error "failed to connect to 81.159.21.93: no route to host" I can ping the server fine externally and have disable UFW. I have added port forwarding to the router and check forums but cannot find a solution.

I am trying to connect directly using the public ip.

I feel like I am probably doing something stupid, maybe someone can help.

> `~$ ifconfig
enp3s0    Link encap:Ethernet  HWaddr 00:1b:78:9d:c9:62
          inet addr:192.168.1.96  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:78ff:fe9d:c962/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5098 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1429 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1476981 (1.4 MB)  TX bytes:263130 (263.1 KB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6122 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6122 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:385128 (385.1 KB)  TX bytes:385128 (385.1 KB)`
  • Since you can connect from within the LAN, your Ubuntu system (and your server) seem to be clearly working properly. Troubleshooting your router settings and other network quirks do not seem Ubuntu-related. – user535733 Nov 23 '18 at 14:47
  • That was my initial thought, However I previously had ubuntu 18 on this machine and I could connect fine through the same network. I can also ping the machine ok from external. I feel I messed something up when configuring static IP. – Andy EcoNat Dec 4 '18 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.