1

I am facing a strange issue. I can heard audio from youtube and other downloaded video files from my ubuntu. I have bought some courses from udemy. Surprisingly, there is no audio when I play those videos on my browser. I have changed the browser but no help. I even downloaded the video to my pc and play from that. Video is running but there is no audio! I don't understand what's the problem as other videos is running with audio.

This is the property of the video from where I am NOT getting any sound.

enter image description here

And This is the property of the video from where I am getting sound.

enter image description here

Note: videos from udemy is running correctly (with audio) at windows 10 in my other pc.

============== Update ===================

I found the problem! Cable of my headphone is so small that can't reach to my ear if I directly insert it at speaker port. That's why, I use an extension cable. But, with the cable I can't hear audio from udemy's video. Without cable, I can hear it. But, it's still strange as I can hear audio from other video's (except udemy's videos) with the extension cable! Any solution for it without changing the cable?

enter image description here

3
  • Please provide list of tested browsers. – mature Nov 23 '18 at 11:12
  • @S_Flash, I've tested on chrome and firefox. This is not issue with browsers. Because, I downloaded the video files on my pc (Ubuntu) and I am not getting any sound from those files. But, those video is playing with audio on my other windows pc – user1896653 Nov 23 '18 at 11:16
  • 1
    Try install run in command line: sudo apt-get install ubuntu-restricted-extras – mature Nov 23 '18 at 11:22
0

To install all media codecs for Ubuntu run in (Ctrl+Alt+T) Terminal:

sudo apt-get update
sudo apt-get install chromium-codecs-ffmpeg-extra

If you need play videos on desktop only, you can install VLC media player from Ubuntu Software (VLC has own codecs).

2
  • I have run this, still the issue exist. the download flies from udemy is mp4. I run it with vlc too. But, there is no audio. Other mp4 is running with audio in my ubuntu. – user1896653 Nov 23 '18 at 11:35
  • I found the problem. Can you please read the Update portion of my post? – user1896653 Nov 26 '18 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.