19

I am a newbie in Linux. I decided to install Kubuntu 11.10 on it and I already have personalized it quite a bit.

I've also realised that Linux is much more sensitive when you reboot it in comparison to Windows! ;)

I switched off the laptop once without properly pressing reboot, and since then the buttons and the writing in the windows in the very top seem too big.

Looks like a bug to me. And if you make the windows smaller it looks really strange and the close and minimize and resize buttons disappear.

I have already once fixed this by inserting the kubuntu cd, but I've forgotten how I did it. I think it was something like restore distribuion or so, but all personalizations kept the same, only the windows were displayed normally (which I of course intended!)

So, how can I restore KDE?

13

To reset you user's KDE modifications to defaults open a terminal and type

mv ~/.kde4 ~/.kde4.old

Log off and log back in and all the KDE settings will be recreated fresh.

That will move the folder where KDE keeps his settings in to another folder with .old in the end of the name. When you log in KDE will create a new .kde4 folder and all the settings used will be the default.

If you want to restore the previous settings you need to have a backup in your home folder inside the .kde4.old folder.

| improve this answer | |
12

The above answer didn't work for me.

I had fiddled with the panels and the solution provided here worked for me. For quick reference, I'm giving the steps below.

  1. Log out of your kde desktop
  2. Open a console session by pressing Ctrl+Alt+F1
  3. Give your username and password
  4. Run rm -rf .kde/share/config/plasma-*
  5. now you can log out of the console session by logout command or pressing Ctrl+D
  6. Now go back to your default graphical session by pressing Ctrl+Alt+F7
  7. now log in and you will see your fresh new default panels

Update for KDE 5

For some versions of KDE, first console session (Ctrl+Alt+F1) is used for UI, not the seventh.

Use second console (Ctrl+Alt+F2) in step 2

Use the first console (Ctrl+Alt+F1) in step 6.

| improve this answer | |
  • I didn't try this but it seems to me more appropriate, i.e. simply remove the configurations that concern KDE's appearance (as it seems to be what the OP was seeking). Most of the instructions found in fora, contain I think the "danger", for a new user, to let him (re)move permanently (access to) the complete ~/.kde directory which might hold "sensitive" data, e.g. Kmail e-mails (...one of the most important directories that holds also data is ~/.kde/share/apps). – Nikos Alexandris May 7 '13 at 9:16
  • This saved me for a 2nd time! It's really annoying that some (problematic?) plasma widgets can cause a non-working KDE. – Nikos Alexandris Dec 16 '13 at 11:43
11

On KDE Plasma Version 5.9.4 (for Kubuntu 17:04):

EITHER

rm ~/.config/plasma-org.kde.plasma.desktop-appletsrc

OR (in order to preserve the old configuration file just in case):

mv ~/.config/plasma-org.kde.plasma.desktop-appletsrc ~/.config/plasma-org.kde.plasma.desktop-appletsrc-old

Then log out of KDE and log back in.

| improve this answer | |
  • Works for Ubuntu 18.04 with plasma 5.12.5 – Katu May 29 '18 at 12:50
1

This question is quite old but still valid. So, I'm answering it with a solution that applies to current KDE which is KDE5/Plasma.

Just deleting .kde/share/config/kdeglobals file do the "reset" trick. So,

$ rm .kde/share/config/kdeglobals
$ logout

Then, just log back in.

| improve this answer | |
0

The Above works in OpenSuSE 13.2 as well and appears to be the best answer for Plasma except there are .kde and .kde4 and .kde5 spaces for 13.2 and I should imagine others there could be the same. So 4. becomes:

rm -rf .kde4/share/config/plasma-*

As always I would recommend copying the three files found this way to an ../old directory first. Also I would point out the source of the problem is it is incredibly easy to hit the "x" in the bottom part of the plasmoid desktop folder so lock your widgets at all times!

Another issue is the non-obvious drag and drop you have to hover at the edge of the desktop folder being careful to not hit the x and pull the tab around to pull the desktop folder probably why the folder disappeared. I agree I cannot find another method documented which strikes me as odd.

| improve this answer | |
0

None of the above worked, including switching the compositor, resetting the compositor, and removing all the config files listed.

What did work for my KDE was to change the theme to something else, confirm the window resize worked, then was able to switch back with resize still working.

| improve this answer | |
  • 1
    This does not answer the question - this is a Ubuntu Q&A site, not OpenSuse. – fosslinux Apr 4 '18 at 22:36
0

I had a similar problem.

I fixed the problem by going on system settings, then to Display and monitor and changing the compositor. This can be done by changing the rendering backend.

| improve this answer | |
0

For Plasma I did the following, which is better because one can recover from it...

cd ~/.config; ls *plasma* | xargs -n1 -I% echo mv % %.bak
cd ~/.cache; ls *plasma* | xargs -n1 -I% echo mv % %.bak
| improve this answer | |
-1

After I boot up my Kubuntu 18.04, I persistently lost the desktop icon setup to default (all the icons were packed up to the top) that is set up on boot process. To cure this problem, first I recreate icon arrangements on my desktop.

Using Konsole, cd to go to default. There is a hidden directory .config. Do cd .config . Then, I sudo copy the .config/plasma-org.kde.plasma.desktop-appletsrc to something like .config/plasma-org.kde.plasma.desktop-appletsrc.save. This saves the new desktop settings you wanted to preserve (This plasma-org.kde.plasma.desktop-appletsrc is continuously updated as you modify the desktop icons and setup.).

Then, log out your current user session. Then, without rebooting, login to the same user session. Then, the desktop is restored to what you wanted. Once that plasma-org*.save file was created in .config, you can copy it back anytime whenever you have the same problem to plasma-org.kde.plasma.desktop-appletsrc.

| improve this answer | |
  • 2
    Why did you use sudo to copy files within your own user home directory? – David Foerster Aug 29 '18 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.