2

I need to use CUDA for work and have upgraded Ubuntu without checking (my bad) whether CUDA supports Ubuntu 18.10, turns out it doesn't: https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html The last supported version is Ubuntu 18.04.5. When do you think CUDA will support Ubuntu 18.10 ? And if it'll take a while, what would be the best way to downgrade my version to 18.04 ? Thanks for your time.

  • Ubuntu 18.04.5 is imaginary right now. While it is likely to happen, it won't be started for years. Downgrading is possible, but not tested or supported - the recommended method is to backup your data and clean-install the earlier release of Ubuntu. – user535733 Nov 21 '18 at 20:12
  • An earlier CUDA version may work fine without needing special packages or non-Ubuntu Nvidia drivers. – ubfan1 Dec 22 '18 at 16:37
2

I would recommend to try it even if it's not supported before trying to downgrade. CUDA also worked on 18.04 before it was supported and there is a CUDA-package in the Cosmic sources.

Use the installation guide provided here by eromod:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt update

sudo ubuntu-drivers autoinstall

reboot

sudo apt install nvidia-cuda-toolkit gcc-6

nvcc --version
2

I have successfully installed CUDA 10.0 on Kubuntu 18.10. You need the runfile and gcc version 6.

  1. Go to the CUDA download site. Click on Linux -> x86_64 -> Ubuntu -> 18.04 (although we have 18.10) -> runfile (local).

  2. Open a new terminal environment with CtrlAltF2 (I think on Ubuntu the default windows environment is on F7, while in Kubuntu is on F1) and login as root.

  3. Stop the display manager in order to stop the X server and install the drivers successfully. For me, on Kubuntu 18.10 that was achieved with:
    service sddm stop
    To find out your display manager, you can try running
    pgrep -l dm

  4. Run the CUDA installer with the override option:
    ./cuda_10.0.130_410.48_linux --override
    The override option will ignore the compiler version check. CUDA requires gcc version 6, but the installation goes fine with gcc version 8 too. The override option allow us to proceed using a later version of the compiler. Install the drivers, the toolkit and the samples too.

  5. Restart the desktop manager
    service sddm start
    and switch again to the desktop environment.

  6. Add the CUDA include directory and the CUDA library directory to your .bashrc file. I have installed CUDA under /usr/local/cuda-10.0, so I had to add
    export PATH=$PATH:/usr/local/cuda-10.0/bin export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/cuda-10.0/lib64/

  7. Go to the samples directory and compile them. This time gcc version 6 is required. Install it
    sudo apt-get install g++-6
    and compile the samples using g++ version 6 as the compiler
    make HOST_COMPILER=g++-6

Done!

1

I cannot tell when it will be supported, but for the moment, from current experience, cuda is not supported in ubuntu 18.10 as it uses xserver abi 24 while the nvidia drivers still only support abi 23

On the other hand, having upgraded without checking for issues and needing an interim solution, you can add the bionic main repository to your sources.list

deb http://us.archive.ubuntu.com/ubuntu/ bionic main

and downgrade the xserver packages (xserver-xorg-core and xserver-xorg-video-*)

I'm using cuda 10 from NVidia's repository at

deb http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64 /

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.