0

I have a DL560 GEN10 with a smart array. When I boot I only see 680GB of the logical drive. The Logical drive is eight 1.2TB drives in a raid 50 so it should be about 6TB. I installed the OS on the SSD and can't see the entire logical drive when boot or booted with the cd. I have also tried booting in bios legacy mode but it didn't help. I also changed the disk label to GPT and reboot but that didn't help.

Ubuntu 16.4.5

I know 18 is the latest supported version but we have mostly 16.04 so I wanted to stay with it for now.

2

I don't think you're in luck. https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00019076en_us#N10238 is not mentioned to be supported for Ubuntu at all (not even 18.04).

Might be the drives only report what system can read from them without a proper driver, and 680GB is what it gets from the device.

Your best shot is probably sending a support request to HP, since this hardware is VERY specific and not something people have at home computers. I'd love to help but never had either of the hardware raids provided along with DL560 GEN10

| improve this answer | |
1

While not always the case, sometimes these issues have to do with physical block sizes on the underlying disks or logical arrays, for example native 4k sector sized drives, etc. I've been able to get around these issues before using three different strategies:

1) The first option is to use ZFS to create a new logical volume on-top of the existing logical drive, and then create ext4 partitions on top of the ZFS volumes. ZFS plays nicer with the underlying arrays and ext4. To do this, you would boot from the CD, install and configure ZFS, setup new ext4 partitions, and then reboot and re-install the OS ontop of the existing ext4 partitions.

2) Another possibility, is within your hardware RAID controller, try re-creating your logical drive using 512 byte sector sizes (if that's an option), and then try reinstalling. It's possible (but unlikely) this would then just "work" and you could install your OS from your boot disk as usual.

3) A more hacky solution which isn't ideal for a variety of reasons but could get your space, would be to split up the underlying logical array into several 600GB logical RAID-0 arrays, and then use software raid under Linux to make those appear as one large volume. This would take a bit more work to do.

| improve this answer | |
  • 1
    If you are not familiar with ZFS, if that is an option, I'd recommend it; ZFS has a lot of nice features. – Mark Stewart Nov 21 '18 at 19:11
0

Even once the Ubuntu 16.4 was online and updated I was still seeing the issue. Getting online took me a bit because it also seemed report the interfaces differently depending on where I looked. After I had interface issues I decided it wasn't going to work.

I ended up going to 18.04 which wasn't idea but it started to work at that point. I saw an error when I ran fdisk that the raid couldn't be a dos partition. I updated the partition to gpt and it worked after that.

As a side not to someone else finding this ESX 6.7 looks to be working. The network came up fine and it sees the entire raid.

I believe Centos 6+ will work also but did not have time to confirm.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.