0

I've used AWS Lightsail for over a year without issues. But recently cannot compile software on Ubuntu, which started shortly after upgrading to Ubuntu 18.04 LTS although not immediately.

After a lot of troubleshooting/googling to fix current instance, I created a brand new instance to isolate my testing and ran into the same issue.

Can anyone point me to the next step I may look at to troubleshoot and successfully compile software?

This occurs with several applications but I'm using nginx as an example. I removed my launch scripts and boiled it down to basic nginx install.

  1. Create new Lightsail instance (Linux, OS only, Ubuntu 18.04 LTS)

  2. SSH into instance as ubuntu@IP_address

  3. sudo apt update && sudo apt upgrade

  4. Install build-essential and nginx dependencies, some may already be installed and are skipped sudo apt install build-essential libpcre3 libpcre3-dev zlib1g zlib1g-dev openssl libssl-dev

  5. Download nginx stable version wget http://nginx.org/download/nginx-1.14.1.tar.gz

  6. Extract files and move into nginx directory tar -zxvf nginx-1.14.1.tar.gz && cd nginx-1.14.1/

  7. ./configure

  8. make

This is where I get several errors like this.

cc -c -pipe  -O -W -Wall -Wpointer-arith -Wno-unused-parameter -Werror -g  -I src/core -I src/event -I src/event/modules -I src/os/unix -I objs -o objs/src/core/nginx.o src/core/nginx.c

Full console: https://pastebin.com/qsbh5CDH

It could be warnings but make does not exit successfully.

make[1]: Leaving directory '/home/ubuntu/nginx-1.14.1'

I try running sudo make install but it also does not complete successfully.

$ sudo make install
make -f objs/Makefile install
make[1]: Entering directory '/home/ubuntu/nginx-1.14.1'
test -d '/usr/local/nginx' || mkdir -p '/usr/local/nginx'
test -d '/usr/local/nginx/sbin' \
        || mkdir -p '/usr/local/nginx/sbin'
test ! -f '/usr/local/nginx/sbin/nginx' \
        || mv '/usr/local/nginx/sbin/nginx' \
                '/usr/local/nginx/sbin/nginx.old'
cp objs/nginx '/usr/local/nginx/sbin/nginx'
test -d '/usr/local/nginx/conf' \
        || mkdir -p '/usr/local/nginx/conf'
cp conf/koi-win '/usr/local/nginx/conf'
cp conf/koi-utf '/usr/local/nginx/conf'
cp conf/win-utf '/usr/local/nginx/conf'
test -f '/usr/local/nginx/conf/mime.types' \
        || cp conf/mime.types '/usr/local/nginx/conf'
cp conf/mime.types '/usr/local/nginx/conf/mime.types.default'
test -f '/usr/local/nginx/conf/fastcgi_params' \
        || cp conf/fastcgi_params '/usr/local/nginx/conf'
cp conf/fastcgi_params \
        '/usr/local/nginx/conf/fastcgi_params.default'
test -f '/usr/local/nginx/conf/fastcgi.conf' \
        || cp conf/fastcgi.conf '/usr/local/nginx/conf'
cp conf/fastcgi.conf '/usr/local/nginx/conf/fastcgi.conf.default'
test -f '/usr/local/nginx/conf/uwsgi_params' \
        || cp conf/uwsgi_params '/usr/local/nginx/conf'
cp conf/uwsgi_params \
        '/usr/local/nginx/conf/uwsgi_params.default'
test -f '/usr/local/nginx/conf/scgi_params' \
        || cp conf/scgi_params '/usr/local/nginx/conf'
cp conf/scgi_params \
        '/usr/local/nginx/conf/scgi_params.default'
test -f '/usr/local/nginx/conf/nginx.conf' \
        || cp conf/nginx.conf '/usr/local/nginx/conf/nginx.conf'
cp conf/nginx.conf '/usr/local/nginx/conf/nginx.conf.default'
test -d '/usr/local/nginx/logs' \
        || mkdir -p '/usr/local/nginx/logs'
test -d '/usr/local/nginx/logs' \
        || mkdir -p '/usr/local/nginx/logs'
test -d '/usr/local/nginx/html' \
        || cp -R html '/usr/local/nginx'
test -d '/usr/local/nginx/logs' \
        || mkdir -p '/usr/local/nginx/logs'
make[1]: Leaving directory '/home/ubuntu/nginx-1.14.1'

Thank you in advance. I found similar compile warning errors on nginx boards but none of the fixes worked. This is also not specific to nginx for me. It occurs when compiling other software on Lightsail Ubuntu 18.04 as well.

Ian

  • 2
    But I don't see any errors in your log. -Werror is compiler switch not an compiler error, and leaving directory is also normal message. – Alvin Liang Nov 21 '18 at 14:15
  • 1st, thank you for responding. These steps are part of my usual install script but nginx doesn't successfully install or run as usual. Shouldn't make finish with exit status [0] if successful? – iangetz Nov 21 '18 at 14:20
  • 1
    If you try to run, what happens? – davidbaumann Nov 21 '18 at 15:53
  • 1
    do you echo $? after make install? It does not look like it has any errors. make[1] is not exit code. – Alvin Liang Nov 21 '18 at 16:17
  • Well, thank you. It appears I don't have an issue. I could not run nginx after this but it appears related to permissions which I didn't have to set before either. Nonetheless, not compiler error... The output of echo $? was 0 so I was mistaken by the make[1]. I also tried compiling other software I typically use such as FFmpeg which still doesn't compile but I may just have a myriad of unrelated issues. Thanks. – iangetz Nov 21 '18 at 19:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.