1

I was trying to copy my EXT4 partition as backup and I accidentally putted my NTFS partition containing my data on the dd command.

Now my data is lost :(

I've tried testdisk but it wasn't able to find partition. What should I do?

Update: This was the command I ran:

dd if=/dev/sda2 of=/dev/sda1 bs=64K conv=noerror,sync
  • Exactly what did tou run? Please update your question with the command you did run. – Soren A Nov 21 '18 at 10:05
  • @SorenA this is what I ran dd if=/dev/sda2 of=/dev/sda1 bs=64K conv=noerror,sync – HQuser Nov 21 '18 at 10:06
  • 1
    What is overwritten is gone. dd copies data from source (if=) to destination (of=) and overwrites data on destination. Testdisk can only recover data that hasn't been overwritten. A current backup is your only hope now. – Soren A Nov 21 '18 at 10:09
  • Is there any way to recover what can be recovered by repairing the filesystem? – HQuser Nov 21 '18 at 10:11
  • No! ddcopies block for block and overwrites the destination - what is overwritten is gone. – Soren A Nov 21 '18 at 10:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.