0

I recently installed 18.10 on an old 4th gen Core i5 desktop and I'm seeing a peculiar issue with the sleep/wake behaviour. The computer sleeps normally, but everytime I wake it, the screen isn't the login window, rather it is, what I can only assume is a screenshot of when I put the computer to sleep. I cant' interact with it, it's just a frozen screen.

I found this question from a long time back, and tried the trick in there, press Ctrl + Alt + F1, and it works everytime.

I've decided to try out Ubuntu/Linux after a long macOS hiatus and so I'm not sure if the response to that question, reconfiguring the desktop manager is the correct answer. I have searched syslog for any intuitive errors, but didn't find anything. Hoping someone here has run into a similar issue and can help out.

1
  • I'd like to add one more observation, after this special wake operation, the favourites bar shortcuts won't work - Super + numbers. I have to restart the PC in order to get them to work again. Hopefully it's helpful. – chin7an Nov 21 '18 at 2:29
1

I figured out what I was doing wrong. I used Alt to suspend the computer, which apparently causes the strange behaviour. The correct way is to long-click the shut-off button, which changes it to the suspend button.

I have a follow-up question to ask for help understanding the behaviour with the Alt key here - What does pressing Alt do when suspending the computer?

0

I doubt pressing Alt to suspend is the issue, I tried both and I can see very the same output. After resuming I am on wrong screen and I need to still switch to Screen 1 with Ctrl+Alt+F1 keys.

Pressing Alt and keeping pressed Power button should do the same.

1
  • I solved the issue on my local desktop by uninstalling all gnome-shell extensions in my ~/.local/share/gnome-shell/extensions/, which are not installed from deb packages and also removed gnome-shell-extension-appindicator package – MarekN Jan 3 '19 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.