0

Disclaimer: I have read the other questions relative to my issue (1, 2, 3, 4, etc.). However, I still have trouble keeping FDE as my default web browser.


Background

I have successfully installed Firefox Developer Edition (FDE) in /opt/firefox_dev/. It runs well, is up-to-date (64.0b11 (64-bit) on aurora channel),…

I have also created the file ~/.local/share/applications/firefox_dev.desktop, which content is:

[Desktop Entry]
Name=Firefox Developer Ed
GenericName=Firefox Developer Ed
Exec=/opt/firefox_dev/firefox %u
Terminal=false
Icon=/opt/firefox_dev/browser/chrome/icons/default/default128.png
Type=Application
Categories=Application;Network;X-Developer;
Comment=Firefox Developer Ed Web Browser.
StartupWMClass=Firefox Developer Edition

I have only a handful of mimeapps.list files — one of which I'm supposed to modify: ~/.config/mimeapps.list. Its content is:

[Default Applications]
x-scheme-handler/mailto=thunderbird.desktop
message/rfc822=thunderbird.desktop
text/xml=firefox_dev.desktop
application/xml=firefox_dev.desktop
application/rss+xml=firefox_dev.desktop
application/rdf+xml=firefox_dev.desktop
image/gif=org.gnome.gThumb.desktop
image/jpeg=org.gnome.gThumb.desktop
image/png=org.gnome.gThumb.desktop
video/webm=firefox_dev.desktop
application/x-xpinstall=firefox_dev.desktop
image/bmp=org.gnome.gThumb.desktop
image/tiff=org.gnome.gThumb.desktop
image/x-bmp=org.gnome.gThumb.desktop
image/x-ico=org.gnome.gThumb.desktop
image/x-png=org.gnome.gThumb.desktop
image/x-pcx=org.gnome.gThumb.desktop
image/x-tga=org.gnome.gThumb.desktop
image/xpm=org.gnome.gThumb.desktop
image/svg+xml=org.gnome.gThumb.desktop
audio/x-vorbis+ogg=vlc.desktop
audio/ogg=vlc.desktop
audio/vorbis=vlc.desktop
audio/x-vorbis=vlc.desktop
audio/x-speex=vlc.desktop
audio/opus=vlc.desktop
audio/flac=vlc.desktop
audio/x-flac=vlc.desktop
audio/x-ms-asf=vlc.desktop
audio/x-ms-asx=vlc.desktop
audio/x-ms-wax=vlc.desktop
audio/x-ms-wma=vlc.desktop
audio/x-pn-windows-acm=vlc.desktop
audio/vnd.rn-realaudio=vlc.desktop
audio/x-pn-realaudio=vlc.desktop
audio/x-pn-realaudio-plugin=vlc.desktop
audio/x-real-audio=vlc.desktop
audio/x-realaudio=vlc.desktop
audio/mpeg=vlc.desktop
audio/mpg=vlc.desktop
audio/mp1=vlc.desktop
audio/mp2=vlc.desktop
audio/mp3=vlc.desktop
audio/x-mp1=vlc.desktop
audio/x-mp2=vlc.desktop
audio/x-mp3=vlc.desktop
audio/x-mpeg=vlc.desktop
audio/x-mpg=vlc.desktop
audio/aac=vlc.desktop
audio/m4a=vlc.desktop
audio/mp4=vlc.desktop
audio/x-m4a=vlc.desktop
audio/x-aac=vlc.desktop
audio/x-matroska=vlc.desktop
audio/webm=vlc.desktop
audio/3gpp=vlc.desktop
audio/3gpp2=vlc.desktop
audio/AMR=vlc.desktop
audio/AMR-WB=vlc.desktop
audio/mpegurl=vlc.desktop
audio/x-mpegurl=vlc.desktop
audio/scpls=vlc.desktop
audio/x-scpls=vlc.desktop
audio/dv=vlc.desktop
audio/x-aiff=vlc.desktop
audio/x-pn-aiff=vlc.desktop
audio/wav=vlc.desktop
audio/x-pn-au=vlc.desktop
audio/x-pn-wav=vlc.desktop
audio/x-wav=vlc.desktop
audio/x-adpcm=vlc.desktop
audio/ac3=vlc.desktop
audio/eac3=vlc.desktop
audio/vnd.dts=vlc.desktop
audio/vnd.dts.hd=vlc.desktop
audio/vnd.dolby.heaac.1=vlc.desktop
audio/vnd.dolby.heaac.2=vlc.desktop
audio/vnd.dolby.mlp=vlc.desktop
audio/basic=vlc.desktop
audio/midi=vlc.desktop
audio/x-ape=vlc.desktop
audio/x-gsm=vlc.desktop
audio/x-musepack=vlc.desktop
audio/x-tta=vlc.desktop
audio/x-wavpack=vlc.desktop
audio/x-shorten=vlc.desktop
audio/x-it=vlc.desktop
audio/x-mod=vlc.desktop
audio/x-s3m=vlc.desktop
audio/x-xm=vlc.desktop

[Added Associations]
x-scheme-handler/mailto=thunderbird.desktop
message/rfc822=thunderbird.desktop
image/jpeg=inkscape.desktop;gimp.desktop;firefox_dev.desktop;
text/css=atom.desktop;
application/x-subrip=atom.desktop;
image/png=gimp.desktop;inkscape.desktop;eog.desktop;firefox_dev.desktop;org.gnome.gThumb.desktop;
x-scheme-handler/http=firefox_dev.desktop;
x-scheme-handler/https=firefox_dev.desktop;
x-scheme-handler/ftp=firefox_dev.desktop;
x-scheme-handler/chrome=firefox_dev.desktop;
text/html=firefox_dev.desktop;
application/x-extension-htm=firefox_dev.desktop;
application/x-extension-html=firefox_dev.desktop;
application/x-extension-shtml=firefox_dev.desktop;
application/xhtml+xml=firefox_dev.desktop;
application/x-extension-xhtml=firefox_dev.desktop;
application/x-extension-xht=firefox_dev.desktop;
text/csv=atom.desktop;
application/pdf=pdfshuffler.desktop;inkscape.desktop;
text/xml=firefox_dev.desktop;
application/xml=firefox_dev.desktop;
application/rss+xml=firefox_dev.desktop;
application/rdf+xml=firefox_dev.desktop;
image/gif=firefox_dev.desktop;org.gnome.gThumb.desktop;
video/webm=vlc.desktop;firefox_dev.desktop;
application/x-xpinstall=firefox_dev.desktop;
application/postscript=evince.desktop;inkscape.desktop;
image/x-eps=gimp.desktop;inkscape.desktop;
image/svg+xml=inkscape.desktop;org.gnome.gThumb.desktop;
image/bmp=org.gnome.gThumb.desktop;
image/tiff=org.gnome.gThumb.desktop;
image/x-bmp=org.gnome.gThumb.desktop;
image/x-ico=org.gnome.gThumb.desktop;
image/x-png=org.gnome.gThumb.desktop;
image/x-pcx=org.gnome.gThumb.desktop;
image/x-tga=org.gnome.gThumb.desktop;
image/xpm=org.gnome.gThumb.desktop;
audio/ogg=vlc.desktop;
audio/vorbis=vlc.desktop;
audio/x-vorbis=vlc.desktop;
audio/x-speex=vlc.desktop;
audio/opus=vlc.desktop;
audio/flac=vlc.desktop;
audio/x-flac=vlc.desktop;
audio/x-ms-asf=vlc.desktop;
audio/x-ms-asx=vlc.desktop;
audio/x-ms-wax=vlc.desktop;
audio/x-ms-wma=vlc.desktop;
audio/x-pn-windows-acm=vlc.desktop;
audio/vnd.rn-realaudio=vlc.desktop;
audio/x-pn-realaudio=vlc.desktop;
audio/x-pn-realaudio-plugin=vlc.desktop;
audio/x-real-audio=vlc.desktop;
audio/x-realaudio=vlc.desktop;
audio/mpeg=vlc.desktop;
audio/mpg=vlc.desktop;
audio/mp1=vlc.desktop;
audio/mp2=vlc.desktop;
audio/mp3=vlc.desktop;
audio/x-mp1=vlc.desktop;
audio/x-mp2=vlc.desktop;
audio/x-mp3=vlc.desktop;
audio/x-mpeg=vlc.desktop;
audio/x-mpg=vlc.desktop;
audio/aac=vlc.desktop;
audio/m4a=vlc.desktop;
audio/mp4=vlc.desktop;
audio/x-m4a=vlc.desktop;
audio/x-aac=vlc.desktop;
audio/x-matroska=vlc.desktop;
audio/webm=vlc.desktop;
audio/3gpp=vlc.desktop;
audio/3gpp2=vlc.desktop;
audio/AMR=vlc.desktop;
audio/AMR-WB=vlc.desktop;
audio/mpegurl=vlc.desktop;
audio/x-mpegurl=vlc.desktop;
audio/scpls=vlc.desktop;
audio/x-scpls=vlc.desktop;
audio/dv=vlc.desktop;
audio/x-aiff=vlc.desktop;
audio/x-pn-aiff=vlc.desktop;
audio/wav=vlc.desktop;
audio/x-pn-au=vlc.desktop;
audio/x-pn-wav=vlc.desktop;
audio/x-wav=vlc.desktop;
audio/x-adpcm=vlc.desktop;
audio/ac3=vlc.desktop;
audio/eac3=vlc.desktop;
audio/vnd.dts=vlc.desktop;
audio/vnd.dts.hd=vlc.desktop;
audio/vnd.dolby.heaac.1=vlc.desktop;
audio/vnd.dolby.heaac.2=vlc.desktop;
audio/vnd.dolby.mlp=vlc.desktop;
audio/basic=vlc.desktop;
audio/midi=vlc.desktop;
audio/x-ape=vlc.desktop;
audio/x-gsm=vlc.desktop;
audio/x-musepack=vlc.desktop;
audio/x-tta=vlc.desktop;
audio/x-wavpack=vlc.desktop;
audio/x-shorten=vlc.desktop;
audio/x-it=vlc.desktop;
audio/x-mod=vlc.desktop;
audio/x-s3m=vlc.desktop;
audio/x-xm=vlc.desktop;
application/x-desktop=atom.desktop;
application/x-sharedlib=atom.desktop;
application/x-executable=atom.desktop;

Problem

When I log in and then open FDE via its launcher, I'm asked whether I'd like to make FDE as default browser as it isn't currently the case. When I click on "Use FDE as my default browser", I got these lines appended to the [Default application] section of ~/.config/mimeapps.list:

[...]
x-scheme-handler/http=userapp-Firefox Developer Edition-803SSZ.desktop
x-scheme-handler/https=userapp-Firefox Developer Edition-803SSZ.desktop
x-scheme-handler/ftp=userapp-Firefox Developer Edition-803SSZ.desktop
x-scheme-handler/chrome=userapp-Firefox Developer Edition-803SSZ.desktop
text/html=userapp-Firefox Developer Edition-803SSZ.desktop
application/x-extension-htm=userapp-Firefox Developer Edition-803SSZ.desktop
application/x-extension-html=userapp-Firefox Developer Edition-803SSZ.desktop
application/x-extension-shtml=userapp-Firefox Developer Edition-803SSZ.desktop
application/xhtml+xml=userapp-Firefox Developer Edition-803SSZ.desktop
application/x-extension-xhtml=userapp-Firefox Developer Edition-803SSZ.desktop
application/x-extension-xht=userapp-Firefox Developer Edition-803SSZ.desktop
[...]

Moreover, the same new *.desktop is appended in [Added Associations]:

[Added Associations]
x-scheme-handler/mailto=thunderbird.desktop
message/rfc822=thunderbird.desktop
image/jpeg=inkscape.desktop;gimp.desktop;firefox_dev.desktop;
text/css=atom.desktop;
application/x-subrip=atom.desktop;
image/png=gimp.desktop;inkscape.desktop;eog.desktop;firefox_dev.desktop;org.gnome.gThumb.desktop;
x-scheme-handler/http=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
x-scheme-handler/https=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
x-scheme-handler/ftp=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
x-scheme-handler/chrome=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
text/html=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
application/x-extension-htm=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
application/x-extension-html=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
application/x-extension-shtml=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
application/xhtml+xml=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
application/x-extension-xhtml=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
application/x-extension-xht=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;
[...]

If I close FDE (or even re-log) and opens it again, it works fine.

However, if I click on a hyperlink in Thunderbird, FDE opens, but asks again to set it as my default browser. ~/.config/mimeapps.list now becomes:

[...]
x-scheme-handler/http=thunderbird.desktop
x-scheme-handler/https=thunderbird.desktop
x-scheme-handler/ftp=thunderbird.desktop
x-scheme-handler/chrome=thunderbird.desktop
text/html=thunderbird.desktop
application/x-extension-htm=thunderbird.desktop
application/x-extension-html=thunderbird.desktop
application/x-extension-shtml=thunderbird.desktop
application/xhtml+xml=thunderbird.desktop
application/x-extension-xhtml=thunderbird.desktop
application/x-extension-xht=thunderbird.desktop

[Added Associations]
x-scheme-handler/mailto=thunderbird.desktop
message/rfc822=thunderbird.desktop
image/jpeg=inkscape.desktop;gimp.desktop;firefox_dev.desktop;
text/css=atom.desktop;
application/x-subrip=atom.desktop;
image/png=gimp.desktop;inkscape.desktop;eog.desktop;firefox_dev.desktop;org.gnome.gThumb.desktop;
x-scheme-handler/http=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
x-scheme-handler/https=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
x-scheme-handler/ftp=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
x-scheme-handler/chrome=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
text/html=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
application/x-extension-htm=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
application/x-extension-html=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
application/x-extension-shtml=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
application/xhtml+xml=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
application/x-extension-xhtml=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
application/x-extension-xht=firefox_dev.desktop;userapp-Firefox Developer Edition-803SSZ.desktop;thunderbird.desktop;
[...]

Obviously, if I close FDE and re-opens it via the desktop launcher, I'm asked again to set it as my default browser…

Question

➥ How to definitively set up FDE as my default browser?

(And, as a side question: "Why is even a userapp-Firefox Developer Edition-803SSZ.desktop created?")

  • Which desktop environment are you using (Gnome 3, KDE, XFCE)? Also, what is the output of xdg-settings get default-web-browser? – Nathaniel M. Beaver Aug 8 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.