Followed this doc to test openstack: https://www.ubuntu.com/openstack/install#workstation-deployment

edit: This is running on ubuntu 16.04

After the conjure-up step, everything eventually starts fine except for neutron-gateway. It is stuck at "waiting for machine." I've tried this on a physical server with 20 physical cores (40 threads), 96GB RAM, and over 200GB of available disk space. So I don't think it is a resource issue. (I've also tried on a VM with 8 cores and 64 GB RAM and got the same result.) I've tried both the stable and edge releases of conjure-up.

Here is lxc list (juju-7e83fd-12 is neutron-gateway):

enter image description here

Here is lxc info --show-log:

enter image description here

I can still get to the openstack dashboard. But under Project | Network | Networks there are no networks configured. Since this is my first time trying openstack, I don't know if that is expected or if it is a symptom of this issue. Any ideas on how to get past this?

  • Can you please show output of juju status Thanks – bogdan Nov 27 at 18:58

I already answered something similar here: No Neutron in Openstack

And based on your comment "there are no networks configured" I feel that we missing neutron-api. Hence I asked to provide juju status so we can see which unit didn't deploy correctly.

So to resolve, You could try to see what went wrong with:

juju debug-log --replay

And see why this specific machine had problems. From your output it seems that ipv4 address is missing. Would be good to understand if there is anything on the network that provides ipv6 - if it is - disable it or if you can not disable just ipv6, spin up lxc container and add dnsmasq to manage DHCP for you. I would take a look inside the container - in this instance, it would be lxc exec juju-7e83fd-12 bash and see if there is anything in the logs of the container. Start with ip a to check for address.

To resolve I would run

juju add-unit neutron-api

This will deploy another machine (lxc) and unit of neutron-api called neutron-api/1 and add all required relationships. Afterwards its a case of

juju remove-unit neutron-api/0

to clean up.

Hope this will help. B

  • Thanks for this reply! Unfortunately I blew it away and re-did it but without conjure-up. So I can't gather more information and troubleshoot any further. I ended up going with this procedure instead - docs.openstack.org/charm-guide/latest/openstack-on-lxd.html. I had much more luck doing it this way. – mrwboilers Nov 28 at 21:42
  • No worries :) and the link in your comment is also good. – bogdan Nov 30 at 8:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.