0

I am trying to get information about my wlan0 connection from iwconfig. When I run iwconfig I get this:

wlan0     no wireless extensions.

When I run ifconfig I get

wlan0 Link encap:Ethernet  HWaddr 00:04:4b:8c:b5:bb  
      inet addr:10.1.10.165  Bcast:10.1.255.255  Mask:255.255.0.0
      inet6 addr: 2603:3021:1101:3800:f85:1f38:ffe1:8333/64 Scope:Global
      inet6 addr: 2603:3021:1101:3800::9cd5/128 Scope:Global
      inet6 addr: fe80::7406:9e58:85f7:9619/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:10246 errors:0 dropped:0 overruns:0 frame:0
      TX packets:5045 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:7299987 (7.2 MB)  TX bytes:469380 (469.3 KB)

My connection has an IP address, and I'm connected to this machine over ssh, so I know the internet is working. If I run nmcli commands it appears to be normal. Why then does iwconfig not display information about this connection.

0

It might be, because iwconfig uses the deprecated WEXT API and your kernel has no support for it enabled. Use the iw tool instead.

Btw, ifconfig is also deprecated for iproute2 (ip link), but the underlying ioctl ABI that it uses is still around.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.