0

Ubuntu 16.04 had been working well for over a year. Then, after a standard software update, as it was very slow I shut down and tried to re-boot.

I was led first to the blank purple screen. Eventually I got the menu to select recovery linux versions. I tried Linux 4.15.0-39-generic and that tried to boot, getting to a black and white screen ending with ---[end Kernel panic - not syncing: VFS: unable to mount root fs on unknown block(0,0)

I tried getting to the Grub prompt but had no success trying to boot manually, using the sugggestions in thread After update in Ubuntu 16.04 I ended up in GNU GRUB and appear to be stuck there

  • try booting into an older kernel version, and see if that works – ARG Nov 20 '18 at 10:51
0

I got the right verion of the vmlinuz file in the boot directory. Then I tried

grub> set root=(hd0,2) grub> linux (hd0,2)/boot/vmlinuz-4.4.0-89-generic root=/dev/sda2 grub> initrd (hd0,2)/boot/initrd.img-4.4.0-89-generic grub> boot

where instead of the above values I used the full path to my vlinuz and initrd files. This, also ansuring to point to sda2, finaly got back to a good boot with all files intact etc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.