1

This question already has an answer here:

I have recently installed Ubuntu 18.04 on my laptop. I tried installing Notepad++ using the following commands:

sudo snap install notepad-plus-plus  

However, after installing it, I can see Notepad ++ is installed but I am unable to open it.

When I run snap run notepad-plus-plus I get the following results:

wine cmd.exe /c echo '%ProgramFiles%' returned empty string, error message   
"wine: WINEARCH set to win64 but '/home/my-username/snap/notepad-plus-plus/common/.wine'  
is a 32-bit installation."

I also tried the suggestion mentioned in

notepad-plus-plus snap does not start on Ubuntu

but can't get Notepad ++ to open.

marked as duplicate by N0rbert, Eric Carvalho, karel, Tom Brossman, Fabby Nov 21 '18 at 19:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    @N0rbert the link does not seem to solve the issue – user3571389 Nov 21 '18 at 10:03
3

That issue is due to big changes made to the snap. This is now using 64bit version of Notepad++ with wine64 on amd64 systems and 32bit version of Notepad++ on i386 systems. This snap is now using wine-platform snap so this has both i386 & amd64 wine pkgs earlier it was using wine-platform-i386 snap which only had wine i386 pkgs. So currently migrating to wine-platform snap from older wine-platform-i386 snap which is not done automatically when user updates the snap caused issue. I'm currently pushing changes to detect if user is still connected snap on older platform should ask to do these commands.

Run these commands will fix your issue.

  • snap disconnect notepad-plus-plus:wine-platform-plug

  • snap install wine-platform

  • snap connect notepad-plus-plus:wine-platform-plug wine-platform:wine-base-stable

If issue still exists then you have to remove win32 WINEPREFIX in order to create win64.

  • rm -r $HOME/snap/notepad-plus-plus/common/.wine
  • It seems that I can add any comment. I tried using snap disconnect notepad-plus-plus:wine-platform-plug but it gives me the following error: error: snap "notepad-plus-plus" has no plug or slot named "wine-platform-plug" The command snap install wine-platform and does the due to installation. However, snap connect notepad-plus-plus:wine-platform-plug wine-platform:wine-base-stable gives an error message: snap connect notepad-plus-plus:wine-platform-plug wine-platform:wine-base-stable – user3571389 Nov 21 '18 at 20:39
  • I haven't tried rm -r $HOME/snap/notepad-plus-plus/common/.wine.Since I am new to Linux, can you please be more elaborate? – user3571389 Nov 21 '18 at 20:40
  • @user3571389 I tried this answer on my Ubuntu 18.04 and it worked without needing to run rm -r $HOME/snap/notepad-plus-plus/common/.wine. All I needed to do to fix the problem with Notepad++ not opening was to run the first three bullet point commands from this answer, one after another. – karel Nov 21 '18 at 22:31
  • 1
    @karel not sure what I have done but it seems to be working now. – user3571389 Nov 21 '18 at 22:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.