0
  1. What happened. After restarting, the system does not boot. It freezes at the Ubuntu logo and the dots.
  2. What I did just before that. I installed anaconda and then I installed Pyinstaller. When running pyinstaller it did not work because it could not find some libraries. But the libraries were there so I created a conf file with the path to the libraries in the anaconda/lib folder and I did sudo ldconfig to update the cache. the system said this path was not a symbolik link but apparently everything worked well because pyinstaller worked well after that. During the anaconda and pyinstaller installation I received a message that there were many packages not needed in the system and that I could get rid of them by an autoremove. Which I did. There were a lot of files but I did not worry much because the whole anaconda installation installed a lot of things (python and stuff) at its own paths so I thought all those files were redundant.
  3. What I did after not booting. First boot repair. After that getting into recovery mode and once that, nothing worked. dpkg gets frozen, doing nothing. same with failsafeX. Now with fsck something interesting happens. This is what I get: fsck:/home/javier/opt/anaconda/lib/libuuid.so.1: no version information available (required by /libx86_64-linux-gnu/libblkid.so.1) fsck from util-linux 2.27.1 fsck.ext4: /home/javier/opt/anaconda/lib/libuuid.so.1: no version information available (required by fsck.ext4) fsck.ext4: /home/javier/opt/anaconda/lib/libuuid.so.1: no version information available (required by /libx86_64-linux-gnu/libblkid.so.1) /dev/sda2 is mounted e2fsck: cannot continue, aborting.

And that's it. Any help would be very valuable. Thanks in advance Javier

0

SOLVED: I went on the "drop to root shell" and I managed to delete the .conf file I created and updated the config cache. After that I could do a fsck. No errors. After that I could enter the dpkg option in the recovery menu. dpkg upgraded the system adn allowed me to log into the system again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.