1

I have a Dell XPS laptop (Ubuntu 16.04) and recently tried to boot into it only to find I get dropped into a BusyBox shell with the prompt:

(initramfs)

It also says that it cannot find the root UUID in order to boot. So I tried to have a look in /dev/disks only to find it doesn't exist! I thought that there may be a hard drive problem so I ran the Dell diagnostic tool and that returns no errors. Also the BIOS can see the hard drive OK.

Next I ran a live usb of Ubuntu 18.04 and the file manager also cannot see the hard drives. I also checked

fdisk -l
lsblk

but they can't see the hard drive either. Checking dmesg | grep -i error I noticed that there were a few errors some relating to a PCIe bus error. I had a look online and found that there is a known bug (or was a known bug) relating to PCIe bus errors and the recommendation was to set the kernel parameter pci=noaer. However, this didn't work on the 16.04 installation.

I am totally stumped and was wondering if anyone had any suggestions?

Thanks in advance.

Update: Following the advice of Alvin Liang below, I went into the BIOS settings and changed the SATA operation from RAID On mode to AHCI and I was able to boot into the OS installation.

  • Could it be that your BIOS settings being reset so SATA is in RAID mode now? Can you change it to AHCI? – Alvin Liang Nov 20 '18 at 8:04
  • Thanks for your advice. That worked! I can't remember changing the BIOS settings or doing a reset but I must of at some point. Thanks again. – crispyninja Nov 20 '18 at 12:29

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.