2

I have GRUB v 2.8.9 (Ubuntu 18.10). I want to install Remix OS in dual boot. I created an entry for Remix OS with GRUB Customizer. But when I'm trying to boot, I don't have any GRUB menu appearing.

So, I tried to fix that by editing /etc/default/grub, but there's no line GRUB_HIDDEN_TIMEOUT. I do have GRUB_TIMEOUT_STYLE="hidden" and GRUB_TIMEOUT="0".

How can I show my GRUB on boot?

  • 3
    Possible duplicate of How to get to the GRUB menu at boot-time? – Mohammad C Nov 19 '18 at 22:35
  • @MohammadC i do not have line: "GRUB_HIDDEN_TIMEOUT", to do this – Dima Soltusyuk Nov 21 '18 at 3:50
  • Just add it to the file and dont forget to update grub – Mohammad C Nov 21 '18 at 3:51
  • @MohammadC i must comment line "GRUB_HIDDEN_TIMEOUT" to solve this problem, but if i add this line in code, and comment it, then, either first variant nor second will not work, because both in 2 variants this line of code will not be compiling – Dima Soltusyuk Nov 21 '18 at 19:27
  • I just wanna to make the grub to open permanently, when i am booting my pc. – Dima Soltusyuk Nov 21 '18 at 19:29
3

Below are my GRUB settings, which do what you want. Make a backup of your /etc/default/grub file and try mine to see if does what you want.

Don't forget to run sudo update-grub any time you edit the file...

I noticed my GRUB_TIMEOUT line doesn't have quotes and

  • 0 means do not time out so skips menu,
  • postive number means skip menu after the given number of secs and
  • -1 means don't skip.

Also try removing the quotes from GRUB_TIMEOUT_STYLE. Also try setting that to menu, not countdown or hidden.

Check out the documentation to see what each setting does.

I think these are the main settings you need.

GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=-1

My current /etc/default/grub

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_THEME=/boot/grub/themes/Aurora-Penguinis-GRUB2/theme.txt
  • Thanks a lot, i'll try it tomorrow, i think it should work. – Dima Soltusyuk Nov 22 '18 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.