35

I was able to add additional keyboard layout in

Settings -> Regional & Language -> Input Sources

Bulgarian (new phonetic) to be specific. SuperSpace works fine, the Gnome icon also works fine for switching. The thing is that the layout is the same for English (US) and Bulgarian (new phonetic). Nothing changes if I try to switch, English (US) in both cases.

Any thoughts on this?
I've googled for about 20 minutes, the problems I've found are mostly not able to Super etc. and Gnome icons not working.

5
  • 1
    Rebooting may be worth a try. Nov 18 '18 at 19:00
  • Yep, I was thinking the same thing, will try it bit later and will leave a note here, thanks. Nov 18 '18 at 19:05
  • 2
    @GunnarHjalmarsson, ineed, it is working after restart. "password you entered was incorrect" was my first clue.. ;d, you can post it as answer so I can close this one or I'll do it tomorrow. Nov 18 '18 at 19:33
  • Great. Please post the answer yourself. Then, after a couple of days, you'll be able to accept it. Nov 18 '18 at 19:35
  • It's worth mentioning that this is a 18.04 bug which is about to be fixed. Oct 7 '20 at 17:14
31

Just for information, if someone is in a similar situation and wants to avoid restarting, this worked for me. TL;DR:

sudo dpkg-reconfigure keyboard-configuration
gsettings reset org.gnome.desktop.input-sources xkb-options
3
  • 3
    Ubuntu 18.04 - didn't work for me. What did work was logging out and logging back in. Jul 18 '19 at 13:19
  • 1
    DONT DO THIS, it can break your language configuration like for me, and I need to configure it again using UI
    – Akim Kelar
    Oct 24 '19 at 9:00
  • 4
    This was enough for me: gsettings reset org.gnome.desktop.input-sources xkb-options
    – funerr
    Nov 8 '19 at 19:04
16

Reloading Gnome after changing the keyboard language also works, which is less "destructive" than than logging out or restarting:

ALT + F2 to bring up the command box, r and Enter to reload.

2
  • 1
    This worked for me on Ubuntu 18.04. Apr 20 '20 at 13:56
  • 1
    Using Linux for a while now. Wow, I learned again new things: alt + F2 plus the "r" command to reload, plus it fixed the keyboard issue. Grazie.
    – Marc
    Jun 19 '20 at 15:10
14

The solution was - restarting the system.

1
  • 2
    Sometimes restarting the system is not possible. For me, logging out and logging back in worked just fine. Jul 18 '19 at 13:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.