3

I have a MacBook (early 2016 model) trackpad and keyboard. I am trying to install Ubuntu on my MacBook. My keyboard works in GRUB (with arrow keys and stuff) but not when Ubuntu boots.

This has happened on Ubuntu 16.10 and Linux Mint 18.1 I believe.

I've tried adding GRUB parameters like acpi=off and i8042.reset from forums. Some forum posts don't even have an answer.

It won't work. I've tried using an USB mouse and that hasn't even worked either. I might even try it again.

Any help would be appreciated.

  • 1
    Anyone there? Please help. Thank you. – Steve Woods Nov 18 '18 at 19:36
  • Check for legacy support in BIOS (ref), consider trying wireless keyboard/mouse, maybe bluetooth type. According to this post Ubuntu doesn't fully support MacBook Pro from 2017, so you may have to manually install a few things. Can't help any further as I don't work with MacBooks. – Sergiy Kolodyazhnyy Nov 18 '18 at 21:50
  • Oh OK. Thank you very much. Mine is early 2016. I've tried Ubuntu, Linux Mint, Fedora and ElementaryOS. Still nothing. How come my keyboard works on GRUB though? – Steve Woods Nov 18 '18 at 21:51
  • Also try github.com/Dunedan/mbp-2016-linux#keyboard--touchpad They've referenced a keyboard driver there, so might give this a try. – Sergiy Kolodyazhnyy Nov 18 '18 at 21:53
  • 2
    I strongly suggest you read the article linked from the post @SergiyKolodyazhnyy referenced. Summary: it's going to be a lot of work to get it to work at all, and even then some things are not going to act right. Consider whether this is something you want to tackle, and if so, approach with patience and in a learning mode. gist.github.com/roadrunner2/1289542a748d9a104e7baec6a92f9cd7 – Organic Marble Nov 19 '18 at 1:54

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.