1

I have Google Earth Pro version 7.3.2.5495 (64-bit) installed using Synaptic Package Manager under Ubuntu 18.04, Gnome Desktop.

It works fine most of the time, but typically after being up for a while, I get the dreaded "cannot connect to server" message. I have tried the "Launch Repair Tool" with no success. I have also tried the "Server Sign Out" followed by "Server Sign in", also with no luck. However, "Exit" followed by re-starting Google Earth always fixes it. Google Chrome, Thunderbird Mail, and all other web-based applications work fine even while GE is failing to connect to server.

There are no crashlogs in ~/.googleearth/crashlogs.

In /var/log/syslog there are messages about google earth requesting kwalletd, and shortly thereafter, kwalletd complains about google earth disconnecting without replying. But this happens on every Google Earth startup, not when the disconnect happens.

Is anyone else seeing this? Any ideas on how to fix it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.