0

Here is the output of my installation attempt:

calvin@Calvins-PC:~/Downloads$ sudo dpkg -i 
openboard_ubuntu_16.04_1.4.1_amd64.deb 
Selecting previously unselected package openboard.
(Reading database ... 425932 files and directories currently 
installed.)
Preparing to unpack openboard_ubuntu_16.04_1.4.1_amd64.deb ...
Unpacking openboard (1.4.1) ...
dpkg: dependency problems prevent configuration of openboard:
openboard depends on libavformat-ffmpeg56 (>= 7:2.8.14); 
however:
Package libavformat-ffmpeg56 is not installed.
openboard depends on libavcodec-ffmpeg56 (>= 7:2.8.14) | 
libavcodec-ffmpeg-extra56 (>= 7:2.8.14); however:
Package libavcodec-ffmpeg56 is not installed.
Package libavcodec-ffmpeg-extra56 is not installed.
openboard depends on libswresample-ffmpeg1 (>= 7:2.8.14); 
however:
Package libswresample-ffmpeg1 is not installed.
openboard depends on libswscale-ffmpeg3 (>= 7:2.8.14); however:
Package libswscale-ffmpeg3 is not installed.
openboard depends on libavutil-ffmpeg54 (>= 7:2.8.14); however:
Package libavutil-ffmpeg54 is not installed.
openboard depends on onboard; however:
Package onboard is not installed.
openboard depends on libqt5multimedia5-plugins; however:
Package libqt5multimedia5-plugins is not installed.

dpkg: error processing package openboard (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for desktop-file-utils (0.23- 
1ubuntu3.18.04.1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2- 
0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
openboard

Could someone help me figure out why this won't install please? And also tell me what to do to get it working.

  • Did you tried sudo apt install ./openboard_ubuntu_16.04_1.4.1_amd64.deb? From where you have downloaded OpenBoard? What is your Ubuntu version? – N0rbert Nov 18 '18 at 13:14
  • The right install command for also installing the dependencies is : $ sudo gdebi openboard_ubuntu_16.04_1.4.1_amd64.deb – Knud Larsen Nov 18 '18 at 13:53
0

It seems that you need to install some dependencies, just read through the log and you'll see that you miss:

  • libavformat-ffmpeg56
  • libavcodec-ffmpeg56
  • libavcodec-ffmpeg-extra56
  • libswresample-ffmpeg1
  • libswscale-ffmpeg3
  • libavutil-ffmpeg54
  • onboard
  • libqt5multimedia5-plugins

You can either install the packages manually or use answer here(copy pasted):

You can install a package and get dependencies from repositories with

sudo gdebi package.deb

If you already installed the package with missed dependencies, you can dowload and install dependencies automatically with

sudo apt-get -f install

Also available is a graphical version gdebi-gtk, linked to .deb nautilus right click action "Open With GDebi Package Installer".

BTW I would define this question as duplicate.

  • Do you know where I can get these: libavformat-ffmpeg56, libavcodec-ffmpeg56, and libavcodec-ffmpeg-extra56? They are outdated now. – Glass Wizzard Nov 18 '18 at 12:47
  • I would try libavformat-dev instead of libavformat-ffmpeg56 libavcodec-dev instead of libavcodec-ffmpeg56 and or libavcodec-extra57 instead of libavcodec-ffmpeg-extra56 – sleepyhead Nov 18 '18 at 12:52
  • OpenBoard demands libavformat-ffmpeg56 and wont accept anything else, any idea where I can get it from? – Glass Wizzard Nov 18 '18 at 13:05
  • I regret to inform you that it might not work forum link and I'd suggest to install from sources they have a tutorial – sleepyhead Nov 18 '18 at 13:33
  • So those dependencies would not be needed if I built it from source? – Glass Wizzard Nov 18 '18 at 14:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.